Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1

    seadoo sportster 4tec issues

    i just got a 2004 sportster the speed and rpm gauges dont work the check engine light and overheat light do work. as far as i can tell all of the fuses are good.
    any idea or common problems with these? Also when u let it idle it runs fine and runs good for a second when u get on the throttle then a alarm goes off but no check lights and it goes into a limp mode, if you kill it and start it back up it theres no alarm but once again get on the throttle and the alarm comes right back on everytime with the limp mode.

    There is absolutely no fault codes in the computer
    the exhaust and engine temps are fine according to the live engine monitor with the sbt scan tool
    Last edited by sr240; 10-16-2012 at 02:58 PM.


  2. #2
    ? Any help?
    thanks

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    What codes is it giving you??
    Those year doos had issues with exhaust sensors and also oil pressure sensors.
    If you tell us the codes we can possibly help.
    I've even seen bad ecu's throw them into limp mode.
    I hope this helps...

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,528
    +1
    1,274
    you need to be able to read the codes from the ecu, otherwise load your money gun.

  5. #5

    Join Date
    Jul 2009
    Location
    Uk
    Posts
    251
    Sounds like a high temp alarm but you need to get the codes or take it to a reputable dealer.

  6. #6
    Any idea on the gauges not working?

  7. #7
    Ok I got a scanner no codes ever come up, the alarm just goes off if you rev it over a certain higher rpm; the check engine light works because if I unplug a sensor or anything it comes on but not when the alarm goes off and goes.into limp mode until u turn the boat off.

  8. #8
    ? Any input?

  9. #9
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,528
    +1
    1,274
    what scanner are you using...did you check the high temp reading for engine/exhaust?

  10. #10
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    You have an alarm but no codes???
    Doesn't make sense??

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 seadoo sportster 4tec
    By hontell in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 04-28-2015, 09:21 AM
  2. FS Seadoo sportster (4tec 04+) boat cover
    By caliburst in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 09-18-2012, 08:37 PM
  3. 07 seadoo sportster 150 ski pylon extension
    By Jimmy in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 07-10-2007, 01:11 PM
  4. seadoo sportster
    By bigd65 in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 06-13-2007, 06:26 PM
  5. Seadoo Sportster 4 tec - power boost ?
    By GrahamGollings in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-12-2005, 11:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •