Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1

    96 seadoo xp runs fine then dies and wont restart

    Ok this is the machine i have rebuilt the motor completely, new starter, battery, rebuilt the carbs new fuel line and rebuilt the jet pump. I can run it on the hose for a half hour in the drive way with no bogging. So when i get it on the river it starts hard and when i do get it running i can go about 200 yards wide open and then it dies like the fuel is shut off 2 hours later it seems to start up hard out of the water and the gets cleaned out and will run fine out of the water. At first i was thinking fuel related but now i am thinking electrical since it is the only thing left. I am just wondering if anyone else has seen this issue and what the cure is. I would guess the stator since that cost more with my luck. Any info will help i would like to get one good ride on this xp.


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by sledder670 View Post
    Ok this is the machine i have rebuilt the motor completely, new starter, battery, rebuilt the carbs new fuel line and rebuilt the jet pump. I can run it on the hose for a half hour in the drive way with no bogging. So when i get it on the river it starts hard and when i do get it running i can go about 200 yards wide open and then it dies like the fuel is shut off 2 hours later it seems to start up hard out of the water and the gets cleaned out and will run fine out of the water. At first i was thinking fuel related but now i am thinking electrical since it is the only thing left. I am just wondering if anyone else has seen this issue and what the cure is. I would guess the stator since that cost more with my luck. Any info will help i would like to get one good ride on this xp.
    check your ground and when you rebuilt the carbs did you replace the needle and seats then check the pop off? The ground has a tendancey to corrode in the rubber. replace the whole thing.

  3. #3
    yes i did do new needle and seats and pop off springs with the ocean pro flame arrestors on it. Would the ground wire be the small black one and not the one going to the starter bolt through the block that i would want to replace. I should probably add the machine sat in storage for a year before i rebuilt the motor. It ran great before and i had rebuilt the carbs a year before that when i first got it then the counter balancer blew out. Also i can get new stators and coils thru parts unlimited but not cdi boxes. I figure since i have spark its not the cdi box but does anyone have aftermarket ones as well. And thanks for the help

  4. #4
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Quote Originally Posted by sledder670 View Post
    yes i did do new needle and seats and pop off springs with the ocean pro flame arrestors on it. Would the ground wire be the small black one and not the one going to the starter bolt through the block that i would want to replace. I should probably add the machine sat in storage for a year before i rebuilt the motor. It ran great before and i had rebuilt the carbs a year before that when i first got it then the counter balancer blew out. Also i can get new stators and coils thru parts unlimited but not cdi boxes. I figure since i have spark its not the cdi box but does anyone have aftermarket ones as well. And thanks for the help
    you need to look at the main ground. check the small one too as that is the one that grounds the coil for corrosion. you can get replacement CDI boxes here but you can also get a total loss system from MSD. I would start small and work your way to the more expensive parts if needed.

  5. #5

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    Do a compression test. Did you rejet your carbs when you went with the open air element filters? What jetting are you currently running and do you have any other mods on your ski?

  6. #6
    make sure you put all your fuel lines on right . my have some backwards ?

  7. #7
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,772
    +1
    129
    When it dies out on the water then gets hard to start pull the plugs and crank it. It sounds like you might have some water intrusion from a bad, or not sealed, gasket.

  8. #8
    The jetting is perfect plugs are brown and not wet. I have put the stock intake back on and jetting and its the same deal. fuel lines are correct I made sure of that, I am wondering about the tank vent if anyone has ever had to replace one of those or not and i need to check the ground cables yet

  9. #9
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,772
    +1
    129
    I have a feeling if you crank it after it dies in the water it will shoot water out the spark plug holes.

  10. #10
    there is no water in the motor.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Gpr1200 runs fine then loses power and exhaust alarm sounds?
    By HDFATB in forum Yamaha PWC Performance (2-stroke)
    Replies: 26
    Last Post: 11-29-2013, 11:52 AM
  2. Replies: 12
    Last Post: 06-13-2012, 12:53 AM
  3. 1994 XP runs good, then slows, quits and runs good.
    By Bruins in forum 2-Stroke Performance
    Replies: 8
    Last Post: 09-08-2011, 10:36 AM
  4. questions on a 95 and 96 seadoo xp
    By dynasty8314 in forum 2-Stroke Performance
    Replies: 11
    Last Post: 06-23-2010, 04:43 PM
  5. FS 96 seadoo xp bare hull and title
    By XP537 in forum Sea Doo 2 Stroke Skis
    Replies: 1
    Last Post: 05-25-2010, 06:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •