Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Jan 2010
    Location
    Upstate new york
    Posts
    14

    2011 Rxp x trim gauge jumping

    I have an '11 rxpx and recently had my wear ring replaced. my trim gauge was working before i dropped it off and now when its trimmed all the way down you can trim it up to neutral but after this point it jumps right to the nose of the ski being all the way up. and sometimes it will just jump all over the place. the actual trim works i think the module was damaged. could the mechanic have damaged this taking my pump off?


  2. #2
    Autism Speaks. Its Time To Listen gOt BoOsT's Avatar
    Join Date
    May 2011
    Location
    Cali
    Posts
    1,413
    +1
    51
    Quote Originally Posted by marck516 View Post
    I have an '11 rxpx and recently had my wear ring replaced. my trim gauge was working before i dropped it off and now when its trimmed all the way down you can trim it up to neutral but after this point it jumps right to the nose of the ski being all the way up. and sometimes it will just jump all over the place. the actual trim works i think the module was damaged. could the mechanic have damaged this taking my pump off?
    im having the same problem! thought i had the vts shaft bound up somehow, but i took it all apart yesterday and it still jumps multiple settings at once. mine started after i changed the nozzle. no damage to the vts could have occurred from removing the pump.

  3. #3

    Join Date
    Aug 2010
    Location
    Massachusetts
    Posts
    225
    +1
    12
    are you sure you are not triggering the vts presets by hitting it up or down twice in rapid succession. did you try trimming slowly?

  4. #4

    Join Date
    Jan 2010
    Location
    Upstate new york
    Posts
    14
    Quote Originally Posted by RobKman View Post
    are you sure you are not triggering the vts presets by hitting it up or down twice in rapid succession. did you try trimming slowly?
    yes i can hit the trim up 4 times and be just under halfway up as soon as it hits this point once you hit the trim button up again it jumps right to the top. i took it to another dealer and they hooked it up to their comp and it wasnt throwing any codes. the mechanic called sea-doo and they told him that the vts module could have been tweaked when the pump was taken off or not properly indexed when the pump was put back on. it looks like my pump and can be trimmed up more but seems to get stuck he also confirmed nothing was jammed it in stopping it from moving

  5. #5
    Autism Speaks. Its Time To Listen gOt BoOsT's Avatar
    Join Date
    May 2011
    Location
    Cali
    Posts
    1,413
    +1
    51
    Quote Originally Posted by marck516 View Post
    yes i can hit the trim up 4 times and be just under halfway up as soon as it hits this point once you hit the trim button up again it jumps right to the top. i took it to another dealer and they hooked it up to their comp and it wasnt throwing any codes. the mechanic called sea-doo and they told him that the vts module could have been tweaked when the pump was taken off or not properly indexed when the pump was put back on. it looks like my pump and can be trimmed up more but seems to get stuck he also confirmed nothing was jammed it in stopping it from moving
    weird man very similar problem...maybe our vts motors are taking a shit. vts shaft only goes on one way with one bolt, no "indexing" about it

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    See if there are any buds updates.
    I've seen updates fix issues like this.

  7. #7

    Join Date
    Jan 2010
    Location
    Upstate new york
    Posts
    14
    yea idk if they didnt disconnect the shaft and tried to pull it off the pump if thats even possible and something got tweaked. before i brought it in to get my wear ring replaced it worked fine. it just seems strange to me that my vts motor would go bad the same time i had the ring replaced

  8. #8

    Join Date
    Jan 2010
    Location
    Upstate new york
    Posts
    14
    Quote Originally Posted by wotxxxsd View Post
    See if there are any buds updates.
    I've seen updates fix issues like this.
    when the ring was replaced it was also time for my 40 hr service i wonder if theres just a bug in my system when he hooked it up the his comp to turn off that alarm?
    being at 2 different dealers tho wouldnt you think that they would see it needed an update?

  9. #9
    Full Throttle or Broke!!! UNSANE's Avatar
    Join Date
    Aug 2008
    Location
    Orlando
    Posts
    721
    +1
    82
    Quote Originally Posted by wotxxxsd View Post
    See if there are any buds updates.
    I've seen updates fix issues like this.
    This happened with me. My trim used to jump around too. Updated to 3.3.4 and my VTS buttons are acting better, along with my suspension buttons. All my button controls seem to react quicker and cleaner now.

  10. #10
    Autism Speaks. Its Time To Listen gOt BoOsT's Avatar
    Join Date
    May 2011
    Location
    Cali
    Posts
    1,413
    +1
    51
    Quote Originally Posted by wotxxxsd View Post
    See if there are any buds updates.
    I've seen updates fix issues like this.
    ill look into this, but it just all of a sudden started happening around 60 hours.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 09-12-2014, 07:46 PM
  2. MFD trim gauge
    By posfit in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-10-2007, 06:40 PM
  3. The RXP Electronic Trim
    By LAB69 in forum 4-Tec Performance
    Replies: 2
    Last Post: 02-04-2007, 04:51 PM
  4. The RXP Electronic Trim
    By LAB69 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 02-03-2007, 10:59 PM
  5. 04 rxp 'sensor' /high idle/trim gauge
    By cdooRXPxtrm in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-17-2006, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •