Results 1 to 6 of 6
  1. #1

    2011 RXP-X Riva Stage 1 performance problems

    Just installed the stage 1 Riva Kit on my 2011 RXP-X and I put it in the water. At first things were great and I noticed nice performance. Than after hitting the first wave I noticed a different kind of noise, almost like a whistle. Now I can only get 5200 RPM and my top speed is 42mph. I am stock, I don't know what to do. Does the ECU need to learn a new fuel map, meaning more air more fuel. We disconnected the battery for about 1 hour and reconnected and still the same thing. Should I recheck all the hoses, maybe the prop came loose. Please all advice would be very helpful.


  2. #2
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    I would check all the exhaust and intercooler hoses first.

  3. #3
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Sounds like a SCer hose came off. Recheck your hoses. Did you torque the prop to 92+ftlbs?

  4. #4
    I didn't have a torque ranch, do you think the prop could have came loose?

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by jp1300r View Post
    Sounds like a SCer hose came off.
    +1

  6. #6

    Join Date
    Apr 2012
    Location
    Winchester Va
    Posts
    56
    Quote Originally Posted by loudmax7 View Post
    I didn't have a torque ranch, do you think the prop could have came loose?
    It would vibrate like mad if it did.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP-X Riva Ride Plate Buck Problem
    By PWCGUY in forum 4-Tec Performance
    Replies: 16
    Last Post: 10-03-2009, 10:09 PM
  2. F/S 2007 rxp with riva stage 3
    By night ryder 26 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 07-13-2008, 09:54 PM
  3. 2005 Low Hours SeaDoo RXP with RIVA Stage II & more
    By GRNGOBLIN in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 05-29-2008, 06:42 PM
  4. rxp-x riva stage 1 mods listed in the uk?
    By boohoo in forum 4-Tec Performance
    Replies: 40
    Last Post: 02-05-2008, 10:42 PM
  5. riva stage 1 kit problems
    By macattack in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-28-2005, 05:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •