Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    Apr 2011
    Location
    Kingston, Ontario, Canada
    Posts
    174

    Out for a ride...Check engine light and codes..

    OUt for a ride on Sunday, running great...hit a small wake with a passenger on the back...check engine light comes on and I see its a P0546 Code. Changed the gauge over to engine temp as I was at least 20 min from the ramp. Got back ok with engine temps at 190 192 194 ish. Didnt go over 20 mph on the way back. Get to the ramp and another code is there now. P2080. Loaded on trailer and went home. Any help on causes? I see that is may be wire short or fault in the sensor, but can't find much on the P2080 code. Have to take to the dealer to clear this code? How much are these sensors? Any prevention for next time out?


    thanks fellas


  2. #2
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    Still not boiling...
    That code reference is what you need.

  3. #3

    Join Date
    Apr 2011
    Location
    Kingston, Ontario, Canada
    Posts
    174
    I found the exhaust sensor was almost completely disconnected. I have hooked it back up and wondering of the engine lamp will go out now or do I have to have it reset by the dealer?

  4. #4
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    It should goto history if they code is no longer active.
    CEL should disappear.

  5. #5
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    P0546 is the EGT sensor you found.
    P2080 is pretty much the same thing.
    Light should clear...

  6. #6
    TDR's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    727
    +1
    10
    My engine light came on today while it was on the hose, and that was the reason.

  7. #7

    Join Date
    Apr 2011
    Location
    Kingston, Ontario, Canada
    Posts
    174
    Thanks, will try and run it to see if it clears..

    cheers


    Quote Originally Posted by stuckmoto View Post
    P0546 is the EGT sensor you found.
    P2080 is pretty much the same thing.
    Light should clear...

  8. #8
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    You know its bad when the sensor falls out of it fitting in the exhaust due to melting the plastic of the sensor.

  9. #9
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,992
    +1
    455

    Out for a ride...Check engine light and codes..

    Quote Originally Posted by lolzer View Post
    You know its bad when the sensor falls out of it fitting in the exhaust due to melting the plastic of the sensor.
    Click image for larger version. 

Name:	ImageUploadedByTapatalk1346156256.811440.jpg 
Views:	113 
Size:	29.3 KB 
ID:	281568

  10. #10
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    LOL there you go...

    Do you know whats funny (well sort of) is when it falls out due to your exhaust being hot enough to liquify plastic, it falls into the bottom of the hull, cools down in the bottom of the hull and error code goes to history, allowing you to operate craft as per normal (out of limp mode), which in turn heats the exhaust enough to melt aluminum.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Check Engine light and message, led tool issues? VIDEO FIXED!
    By fastlane in forum Polaris Open Discussion
    Replies: 9
    Last Post: 09-15-2014, 12:19 PM
  2. 2002 Genesis i Check Engine Light and low RPM
    By waterhead in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 06-28-2011, 08:14 AM
  3. Check Engine light and performance issues Rxp Stage 3
    By trofodotiki in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-03-2011, 03:32 PM
  4. check engine light and error code P0351
    By cawky in forum 4-Tec Performance
    Replies: 16
    Last Post: 03-27-2009, 09:21 PM
  5. Check engine light and msg but no codE?
    By camar0 in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-15-2008, 03:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •