Results 1 to 7 of 7

Thread: Rxp wear ring

  1. #1

    Rxp wear ring

    Hello all,

    A few weeks ago I sucked up a rock with my rxp and then it would only top out around 50. So I lurked this forum and replaced the wear ring and put in a Solas impeller.

    A few questions. I took it out and it pulled like an animal. The odd thing is that from a dead stop when I hit the throttle it acts like it has weeds in the grate but if I roll into its awesome. Any ideas what thats about?

    Second I was rereading manual and it seems I missed the step about drilling holes into the wear ring and installing the wear ring screws. I never took them out in the first place and the wear ring is installed now obviously. Should I take it apart and drill the holes for the screws and reinstall or not bother?

    Thank you in advance for the help.


  2. #2

    Join Date
    Jul 2007
    Location
    Montgomery, AL
    Posts
    257
    +1
    1
    Welcome to the Hulk. What ski do you have, I have an 05 rxp and there are no wear ring screws. Check to see if your prop nose cone is still screwed to the prop, they come off walk up the drive shaft and cause cavitation if you do not score the threads and use red loctite. What year RXP do you have and how many hours are on it?

  3. #3
    Quote Originally Posted by Bama View Post
    Welcome to the Hulk. What ski do you have, I have an 05 rxp and there are no wear ring screws. Check to see if your prop nose cone is still screwed to the prop, they come off walk up the drive shaft and cause cavitation if you do not score the threads and use red loctite. What year RXP do you have and how many hours are on it?
    Thanks for the reply. It's an 06 with about 50 hours on it. I used the loctite thread sealer on the impeller cone not the red lock tite. Was I suppose to put anything around the wear ring to lock it in place?

  4. #4
    Quote Originally Posted by Ynkssws6 View Post

    Thanks for the reply. It's an 06 with about 50 hours on it. I used the loctite thread sealer on the impeller cone not the red lock tite. Was I suppose to put anything around the wear ring to lock it in place?

    Anyone else have any ideals? I'm going on vacation soon and what to get this right before I drive 700 miles lol.

  5. #5

    Join Date
    Jul 2007
    Location
    Montgomery, AL
    Posts
    257
    +1
    1
    Look in the pump tunnel and see if the nose cone is still attached to the prop. If that is still connected then you may be getting some cavitation from a leaking carbon seal. 50 hours is not much but the accordian boot may have shrunk. The boot puts pressure on the carbon seal. you could try putting zip ties on the boot, some people use o-rings but you would have to pull the drive shaft for that and if I pulled the drive shaft I would just replace the carbon seal and the boot. I think there is a thread in the how to section about using the zip ties.

  6. #6
    I was reading that it could also possibly be a pinched neoprene seal too. I'll have to look at that as well. I really hope it's not the carbon seal that sounds like a pain.

  7. #7
    Quote Originally Posted by Ynkssws6 View Post
    I was reading that it could also possibly be a pinched neoprene seal too. I'll have to look at that as well. I really hope it's not the carbon seal that sounds like a pain.
    Update: went to take off the pump last night and the top left bolt was only on hand tight at best. The green cone from Solas was also loose but not off. I'll lake test it this weekend and see what happens.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 RXP wear ring removal?
    By 1ton in forum 4-Tec Performance
    Replies: 32
    Last Post: 08-30-2007, 04:04 PM
  2. OEM RXP wear ring is garbage!
    By ou812 in forum 4-Tec Performance
    Replies: 17
    Last Post: 05-28-2007, 09:13 PM
  3. RXP wear ring replacement
    By driveumhard in forum 4-Tec Performance
    Replies: 1
    Last Post: 03-17-2007, 10:45 AM
  4. Those Going to MUDBUG:: In Need of RXP Wear Ring.....!!!!!
    By VFX_Artist in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-07-2006, 07:40 PM
  5. RXP Wear ring ..
    By Flyer in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 04-17-2006, 06:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •