Results 1 to 3 of 3

Thread: top speed

  1. #1

    Exclamation top speed

    hi everyone,

    im new at this so not sure if im posting this in the right place. i have a yamaha 1200 xl limited, which i just re built top end due to the 3rd oil line going to the 3rd cyl. came off. also i removed cat and installed a D plate and chip, and waveeaters on the power valves. after rebuilt ski was working fine, the 2nd time i was out in the water i noticed that i was running oil rich. and it was smoking a lot. i checked the oil pump and the cable going from the pump to throtle was broke, which for a safety it automatically opens the pump wide open. when this happened i noticed loss of power due to too much oil going to the cyl the ski will do about 60mph in good working condition, now it was 40mph. once fixed it ran perfect until the gas warning came on. i refilled and got the ski back in the water and it had lost power and it idles very low. im thinking it is the fuel filter that is clogged. any suggestions??? thanks in advance for your response!!


  2. #2
    pokplalya22's Avatar
    Join Date
    Jun 2011
    Location
    NY
    Posts
    485
    +1
    4
    Cant hurt to change the filter, then take it from there. If it was running real rich, my guess was that you fouled the plugs. Pull them and check. Check the simple stuff first, its usually the case.

  3. #3
    Quote Originally Posted by pokplalya22 View Post
    Cant hurt to change the filter, then take it from there. If it was running real rich, my guess was that you fouled the plugs. Pull them and check. Check the simple stuff first, its usually the case.
    i changed the fuel filter and ran it for about 15 min. yesterday, it still didnt have all the power i have some oil in the bilge. i removed the exhaust and checked all the hoses going to each of the cylinders and they are all fine. i saw that it is coming from the screen that is in the air box where the carburators are at. im thinking since the pump was wide open for some time if it could have messed anyting up. or it is just getting rid of all the extra oil that was dumped in the cyl. any suggestions??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Stock top speeds?
    By dgmoore in forum 4-Tec Performance
    Replies: 29
    Last Post: 06-15-2016, 05:25 PM
  2. What was your best first mod to get some top speed?
    By meeper in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-17-2005, 01:18 PM
  3. Top speed for stock?
    By omelfata in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-08-2005, 07:25 PM
  4. Has anyone done a wedge back to back for top speed?
    By Burnwater in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-05-2005, 01:57 PM
  5. RXP top speeds
    By Krazy-K in forum 4-Tec Performance
    Replies: 27
    Last Post: 07-03-2005, 10:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •