Results 1 to 5 of 5
  1. #1
    TheEngineer's Avatar
    Join Date
    Aug 2007
    Location
    Tampa, FL
    Posts
    934
    +1
    131

    Anyone aligned a 2012 ski yet?

    I just picked up the motor alignment tool but there's a roadblock. The 2012 P-X pump support has two plastic pegs that stick out and will not allow the alignment plate to be perfectly tightened down against the pump support. You can tighten the bottom bolts, but if you tighten the top bolts the plate will be angled slightly and your alignment rod won't even make it into the hull. I'm stuck and don't know how to approach this. Do I just align the motor left-to-right, and put the same number of shims in place that were used in my old hull (two for each mount)? If I only tighten the bottom two bolts of the plate, there's too much up and down play with the rod in.


  2. #2
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81

    Anyone aligned a 2012 ski yet?

    Might message troyheb or wfo. As Troy had carbon seal issues

  3. #3
    TheEngineer's Avatar
    Join Date
    Aug 2007
    Location
    Tampa, FL
    Posts
    934
    +1
    131
    Shit...Well I just discovered that there is a new pump plate for the P-X. As you can see it's got two additional hole for those stupid plastic pegs to stick through. I doubt I'll be able to find this plate anywhere.

    Click image for larger version. 

Name:	Screen Shot 2012-08-28 at 11.18.30 PM.png 
Views:	135 
Size:	36.5 KB 
ID:	281654

  4. #4
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    time to drill the holes in the right place, make sure they are where they belong as i believe the '12 pump bolts are a smaller diameter ........ try bolting pump to the plate to get the holes lined up right

  5. +1 by:


  6. #5
    TheEngineer's Avatar
    Join Date
    Aug 2007
    Location
    Tampa, FL
    Posts
    934
    +1
    131
    Quote Originally Posted by big john View Post
    time to drill the holes in the right place, make sure they are where they belong as i believe the '12 pump bolts are a smaller diameter ........ try bolting pump to the plate to get the holes lined up right
    That's correct, they downsized the bolts and added these stupid plastic pegs. The plate part # shows up in the OEM part store. I'm going to start calling every dealer in Florida tomorrow morning. I HAVE to get this ski running by the weekend.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Have the riva ecus shipped? Anyone got one on a ski yet??
    By Doug78 in forum Yamaha PWC Performance (4-stroke)
    Replies: 18
    Last Post: 10-20-2009, 08:58 PM
  2. So has anyone pulled flame arrestor out of their X ski yet?
    By Shibby1485 in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-20-2008, 05:14 PM
  3. Anyone here ride the 250 yet?
    By Pistonwash in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 11-25-2006, 09:06 PM
  4. Anyone Wakeboard behind their ski?
    By 05RXPnoob in forum Sea Doo Open Discussion
    Replies: 32
    Last Post: 09-03-2006, 09:17 AM
  5. Anyone here store thier ski outside?
    By Pettee in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 05-02-2006, 08:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •