Results 1 to 9 of 9
  1. #1

    Power loss on my 1999 yamaha 1200 XL Please help..

    hi everyone,

    im new at this so not sure if im posting this in the right place. i have a yamaha 1200 xl limited, which i just re built top end due to the 3rd oil line going to the 3rd cyl. came off. also i removed cat and installed a D plate and chip, and waveeaters on the power valves. after rebuilt ski was working fine, the 2nd time i was out in the water i noticed that i was running oil rich. and it was smoking a lot. i checked the oil pump and the cable going from the pump to throtle was broke, which for a safety it automatically opens the pump wide open. when this happened i noticed loss of power due to too much oil going to the cyl the ski will do about 60mph in good working condition, now it was 40mph. once fixed it ran perfect until the gas warning came on. i refilled and got the ski back in the water and it had lost power and it idles very low. im thinking it is the fuel filter that is clogged. any suggestions??? thanks in advance for your response!!

    I know i posted this in another thread, messed up on the title.


  2. #2
    i changed the fuel filter and ran it for about 15 min. yesterday, it still didnt have all the power i have some oil in the bilge. i removed the exhaust and checked all the hoses going to each of the cylinders and they are all fine. i saw that it is coming from the screen that is in the air box where the carburators are at. im thinking since the pump was wide open for some time if it could have messed anyting up. or it is just getting rid of all the extra oil that was dumped in the cyl. any suggestions?? .
    --------------------------------------------------------------------------------

  3. #3
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    There are some things you need to check since the rebuild. you need to check the reeds and recheck the compression and if you haven't gone through the carbs. it would be another thing to check off the list.

  4. #4
    Quote Originally Posted by mudslanger View Post
    There are some things you need to check since the rebuild. you need to check the reeds and recheck the compression and if you haven't gone through the carbs. it would be another thing to check off the list.
    rechecked compression 120 on all cyl. i changed the spark plugs today took it out to the water and is still doing 44 and 5700 RPM. question how do i know if the reed valves are good or bad? i can check those by taking the carburators off right? thank you for your help!!

  5. #5
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    Also make sure the power valves are cycling fully when starting and stopping the motor. You can also slide the seat back wile riding the ski to see if they are opening. But be cautious as you will be full throttle when the power valves open so make sure you are on calm water.
    There is a possibility of an exhaust leak causing the problem and sliding the seat back to watch the power valves open will allow fresh air in the engine compartment allowing the engine to operate normally if it is an exhaust leak. Let us know what you find.

  6. #6
    Quote Originally Posted by mudslanger View Post
    Also make sure the power valves are cycling fully when starting and stopping the motor. You can also slide the seat back wile riding the ski to see if they are opening. But be cautious as you will be full throttle when the power valves open so make sure you are on calm water.
    There is a possibility of an exhaust leak causing the problem and sliding the seat back to watch the power valves open will allow fresh air in the engine compartment allowing the engine to operate normally if it is an exhaust leak. Let us know what you find.
    it seems like power valves are opening and closing properly, i checked all 3 spark plug boots, replaced spark plugs, fuel filter and it is still doing the same thing it wont go over 45. also when i give it gas once or twice when in the water the RPM's will go down and if i dont give it gas it shuts off. when i took it apart i reused all exhaust gaskets.. will that cause the problem... the rare thing is that the jet ski ran like a champ after rebuild. this happened right after my gas went low. any suggestions will be greatly appreciated.. i would like to fix this before the season ends.

  7. #7
    Quote Originally Posted by nicolasbermudez View Post
    it seems like power valves are opening and closing properly, i checked all 3 spark plug boots, replaced spark plugs, fuel filter and it is still doing the same thing it wont go over 45. also when i give it gas once or twice when in the water the RPM's will go down and if i dont give it gas it shuts off. when i took it apart i reused all exhaust gaskets.. will that cause the problem... the rare thing is that the jet ski ran like a champ after rebuild. this happened right after my gas went low. any suggestions will be greatly appreciated.. i would like to fix this before the season ends.


    Im thinking of taking my carbs out and check the high speed.. i have never done this before any suggestions on what not to do?? thanks!

  8. #8
    I would saw take them apart and look for any debris that may be clogging jets or the little filters. That debris could have been sucked up from the bottom of the tank when it went low

  9. #9
    Quote Originally Posted by kmc View Post
    I would saw take them apart and look for any debris that may be clogging jets or the little filters. That debris could have been sucked up from the bottom of the tank when it went low
    I will be taking it to a good mechanic in my area.. will let you guys know what he finds..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is it worth modifying my 1999 Yamaha 1200 xl ltd
    By canon714 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-30-2015, 04:15 PM
  2. 1999 yamaha 1200 xl power valves
    By Shifflett115 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-28-2013, 02:29 PM
  3. 1999 yamaha 1200 xl power valve plates
    By Shifflett115 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-23-2013, 11:40 PM
  4. 1999 yamaha 1200 xl power valve covers
    By Shifflett115 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-22-2013, 11:09 AM
  5. 1999 Yamaha 1200 XL Limited oil block off
    By lagernuts in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-04-2010, 09:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •