Results 1 to 3 of 3
  1. #1

    xp 650 won't start after running

    my 94 xp 650 will start and run great but when i shutt of and go to restart will crak but not start, by the time i get home 15 minutes it will start and run fine , tried it again last weekend does same thing rode for ten minutes shut off would not start, twenty minutes later starts up, any answer would help a lot!!!


  2. #2
    rotary valve to cover clearance and wear are the common causes for a hot restart issue..

  3. #3
    how do i check for that

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 virage I 800 runs good, then won't start after warm
    By mainepilot in forum Polaris Open Discussion
    Replies: 21
    Last Post: 07-12-2014, 05:38 PM
  2. 1994 Polaris 750 won't start after running for a while
    By april in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-10-2012, 07:14 PM
  3. 2001 GTS - Won't start after being run...
    By Curtis J in forum 2-Stroke Performance
    Replies: 9
    Last Post: 04-12-2010, 11:19 AM
  4. virage won't start after running for a while
    By culby-wan-kanobi in forum Polaris PWC Performance
    Replies: 27
    Last Post: 08-07-2008, 02:14 PM
  5. 2001 XL800 Won't start after sitting
    By michaelj3 in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 07-07-2008, 11:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •