Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1

    2002 Polaris Genesis is losing 1000 RPM at top speed now and then

    hi guys I'm back with another weird problem. I have a 2002 Poaris Genesis 1200 carb that i just got working great and at top speed of 7000 rpms it runs nice and every now and then it drops to 6000 rpms and then goes back up. and then it does it again.

    I am mixing the gas and had the carbs cleaned, that was my problem first i think the carbs was making her die in the water after driving for a bit.

    now the die is gone and the rpms are droping a bit and going back up,, any ideas?
    Last edited by K447; 09-05-2012 at 09:26 AM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Carbs cleaned? What exactly was done?

  3. #3
    I don't really no. But it ficked the dieing problem I was wondering if he miss something as will or do you thing my oil is to rich. Because I have it around 32-1 and I'm slow going down to 40-1. Now I was looking at the carb last night in the boat and seen that the turn screws were..One was up straight and the other two were on a angle. Will that make a differents

  4. #4
    Oh ya the polairs dealer clean the carbs that's all he said. There was a bet of dirt and a bet of water. And I clean the tank out before I put the carbs back on

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    The Keihin carburetors do not have a high speed screw adjustment. the only screw adjustment is for low speed tuning.

    The adjustment screws (one per carburetor) should be roughly equal number of turns out from lightly seated. Mind you, I am saying this without checking the specs in the service manual...

    RPM surging up and down at max throttle could be several things. The possible cause I would worry about is fuel starvation which could burn a piston.

    You (or your dealer) needs to confirm that the entire fuel system is 100% good. Make sure both of the pulse hoses are properly connected to the correct nipples, for example.

  6. #6
    Connected to the right spots. The hoses are only so long. They can only go to the right spot

    Wish you had a picture. I was reading on carbs here and you guys are talking about those lines with the twist tie should be change with clamps. Is that something it might be Coming lose under vibration

    Shit I don't what to burn a piston. That would suck
    Last edited by K447; 09-05-2012 at 09:23 AM.

  7. #7
    Lit me think. Back of carbs last nipple go to bottom of engine middle nipple goes to filter and front nipple goes to bottom of engine. And then there one from the tank and carbs that I don't have to touch because it is join in the middle Did I miss anything

  8. #8
    Hi everyone

    I checked all my lines on the carb and found some loose clamps and changed them with better ones, plus took the zip ties off and put clamps on them too.

    Havent had a problem since then and I have been out on the water 3 times.

    Thanks k447 for all the help,, I'm so happy it's works good.

    Plus I inhooked the whole back wire to the reverse and it hasn't come back on. Wicked. Don't need reverse anyway. I'm all about going forward. Lol.

    Thanks again.

    And if you know anyone looking for a 1200 Polaris engine, carb. I got one.
    Last edited by K447; 09-05-2012 at 09:22 AM.

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Glad to hear it is running better for you!

    7000 RPM is high for that Genesis 1200 motor. Normally should be around 6700, give or take. Is the impeller worn?

    Tell me more about this spare 1200 motor.

  10. #10
    Yup I was rounding it off. That's about right 6700. Anyway the motor was never my problem. It was the carb sucks I bought a nother one. To funny. Will it has 130 130 100. Now the funny think about that is I open it up and the middle that had 130 is the one with the stuck ring the back one is 100 but the us some scoring there the front one is 130 and perfect so I was going to do another bore witch will be .75 I think. It's at 5mm own. I bore it last year or the year before that. Now I wich there was a way to till if the crank was not damage. But there no play or anything. And like I said it wasn't the engine I had problems with and it was always nice and powerfull I'm going to try and find out how to put pictures on here and I can show you everthing I'm talking about.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris genesis I stuck in reverse but machine is not in reverse
    By Canadian in forum Polaris PWC Performance
    Replies: 5
    Last Post: 08-03-2016, 10:10 AM
  2. 2002 Polaris Genesis engine is getting hot and locking up in the water
    By travis ingram in forum Polaris Open Discussion
    Replies: 77
    Last Post: 08-15-2012, 11:01 AM
  3. 2002 Polaris Genesis losing power
    By deepwest563 in forum Polaris PWC Performance
    Replies: 13
    Last Post: 06-17-2011, 11:17 AM
  4. 2002 Polaris Genesis I won't rev past 4000 rpm
    By 440/650 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 06-12-2011, 02:51 PM
  5. F/S 2002 Polaris Genesis in SW Florida
    By PeaceRiverRider in forum Polaris Classifieds
    Replies: 2
    Last Post: 07-19-2008, 07:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •