Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    Speedometer issue

    Hi fellas just registered for this cool forum and love it already. I just purchased a 2007 Sea Doo GTI with 188 hours on it which seems to be mechanically sound, the issue I'm having is that the cluster reads gas level, tach perfectly but no depth, water temp or speed and according to the previous owner it use to read all fine. I checked the harness for proper connectivity and clean prones. Where is the speed sensor on this thing or the infamous wheel? any pics will be gladly appreciated.


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Wheel should be on the bottom in the back of the hull next to the pump.

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Welcome to the Hulk...

  4. #4

    Join Date
    May 2012
    Location
    Upstate NY
    Posts
    111
    +1
    2
    The sensor with the wheel on it is responsible for speed and water temp. I'm pretty sure the depth is a separate sensor.

  5. #5
    Chris crisistc's Avatar
    Join Date
    Jul 2009
    Location
    Savannah, GA
    Posts
    295
    +1
    4
    if you find that you speedo and water temp sensor are broken I have one for sale.

  6. #6
    Wow thanks for the prompt responses and help, I wll be more than glad to buy that part if I can find it but for the life of me I just can't any pics??

  7. #7
    Chris crisistc's Avatar
    Join Date
    Jul 2009
    Location
    Savannah, GA
    Posts
    295
    +1
    4
    Click image for larger version. 

Name:	IMG_0573.jpg 
Views:	53 
Size:	9.1 KB 
ID:	281922
    Click image for larger version. 

Name:	rear.jpg 
Views:	55 
Size:	56.0 KB 
ID:	281923
    The speedo and temp sensor are one unit and can be found on the back of the ski near the arrow, it is supposed to be mounted to the back near the ladder.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screen shot 2012-09-01 at 9.58.57 AM.png 
Views:	107 
Size:	25.8 KB 
ID:	281920  

  8. #8
    Hi CrisisTC, thanks for the awesome pics or else i would've not known that is where it was, here are the pics I took, so I can see clearly the the sensor is missing so how does it attach to the hull and where do the cables go to? Also how much are you selli g this for?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20120901_201525.jpg 
Views:	40 
Size:	50.4 KB 
ID:	281945   Click image for larger version. 

Name:	20120901_201608.jpg 
Views:	38 
Size:	39.0 KB 
ID:	281947   Click image for larger version. 

Name:	20120901_201637.jpg 
Views:	41 
Size:	85.8 KB 
ID:	281946  

  9. #9
    Chris crisistc's Avatar
    Join Date
    Jul 2009
    Location
    Savannah, GA
    Posts
    295
    +1
    4
    The Sensor (speedo and lake temp sensor) attach to the hull with three screws,
    looks like you will need to:
    1. drill a hole for the cable to go through the hull (not very hard to do)
    2. drill small starter holes for the screws to screw into the hull
    3. once installed put marine sealant on the hull and between the sensor so no water will leak in
    3. the speedo will have a harness to hook into near the throttle body

    I am asking $70 shipped for the speedo/water temp sensor, it will include the screws and the connector to connect to your harness.

    Here is a picture of what it looks like with the sensor removed from the hull so that you get a better idea.


    Click image for larger version. 

Name:	IMG_0579.jpg 
Views:	45 
Size:	89.3 KB 
ID:	281956

  10. #10
    Chris crisistc's Avatar
    Join Date
    Jul 2009
    Location
    Savannah, GA
    Posts
    295
    +1
    4
    The GTI was a base model that had less options on it to lower the cost, which is the reason your ski does not have Speed sensor, water temp sensor, or depth sounder. Be sure that you have the harness inside the ski to be able to hook it up if you do want to add this feature.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. speedometer issue f12x
    By Jcrumpley in forum Honda How To & FAQs
    Replies: 1
    Last Post: 10-07-2013, 08:50 PM
  2. Speedometer issues on 1998 stx-1100
    By Kaplanlandscapes in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-24-2012, 01:28 AM
  3. RXP Speedometer issue
    By ziggity in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 08-01-2011, 03:18 PM
  4. 03 GTX SC Speedometer Issue? and Just Saying Hello
    By dan-gtx-sc in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-19-2011, 10:14 PM
  5. Speedometer issue for a STX15f
    By WaterPuppy in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 05-29-2009, 08:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •