Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 45
  1. #1
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948

    Help! RXPX 260 performance issues

    ok so i spent a buttload of money on my rxpx 260 and my speed is lower than it should be. here is every mod i have, xxx charger, vtech 8900 stage3, lightweight valve train, fizzle air, intake mod, riva 3rd gen ic and plumbing, hks blow off valve, et charger cooler,131 degree thermostat, rad 4 torque plate, 15/20srz rrfpr set at 55 with ref line connected.

    speed and rpm are 74-75 at 8380
    boost is just under 14psi (should be higher)

    slip on the charger is good at 24 ft lbs
    compression is 135 in all cylinders (tested cold)
    afr's are good, around 14 till boost kicks in then they drop to high 12's midrange down to around 12.2-12.4 at wot,

    it seems like my boose is low but i am at a loss, i have checked and rechecked everything, what are some weird boost leaks anyone has seen, i am about to try another intake of my other ski just to see. is anyone else running an xxx charger? with my old xx charger i was basically seeing the same boost number. an help at all would be appreciated
    thanks


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I think your slip should be higher ft lbs.

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I just had a 08 rxp 215 and my mechanic tested it at 68 ft lbs.

  4. #4
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    I think you are thinking inch lbs, 24ft lbs is very tight, it was set this tight from Riva right out of the box

  5. #5
    Martin RXT-X's Avatar
    Join Date
    Jul 2011
    Location
    Kemah Tx
    Posts
    665
    +1
    89
    Go with a Motec ECU. You are in the same boat as I was, could not get passed 76 . Got the Motec looked at the logging pictched prop and now 82 MPH . You have more mods then me.

  6. #6
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    Quote Originally Posted by Martin RXT-X View Post
    Go with a Motec ECU. You are in the same boat as I was, could not get passed 76 . Got the Motec looked at the logging pictched prop and now 82 MPH . You have more mods then me.
    What boost #s are you seeing with what charger

  7. #7
    Martin RXT-X's Avatar
    Join Date
    Jul 2011
    Location
    Kemah Tx
    Posts
    665
    +1
    89
    Quote Originally Posted by seadoo02xp View Post
    What boost #s are you seeing with what charger
    Around 16 psi in the Texas heat at the intake manifold with a Rude charger.

  8. #8
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    Quote Originally Posted by Martin RXT-X View Post
    Around 16 psi in the Texas heat at the intake manifold with a Rude charger.
    2rude or 3rude

  9. #9
    Martin RXT-X's Avatar
    Join Date
    Jul 2011
    Location
    Kemah Tx
    Posts
    665
    +1
    89
    3 rude running constantly over 81 in the heat of Houston best recorded 82 dead.

  10. #10
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    Quote Originally Posted by Martin RXT-X View Post
    3 rude running constantly over 81 in the heat of Houston best recorded 82 dead.
    the riva xxx is a step above a 2 rude, i should be seing close to 16 psi at 8500 but im not getting there, even when i can get my ski to rev up to 9k on a holeshot the boost will never touch 15. seems like i have a leak somewhere i just cant find it, ive been chasing this all summer. i finally got an afr and come to find out everything is right where it should be.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2015 Sea Doo RXPX 260 Performance ???
    By Joeram44 in forum 4-Tec Performance
    Replies: 26
    Last Post: 06-22-2016, 11:28 AM
  2. Replies: 1
    Last Post: 11-05-2013, 05:34 PM
  3. FS Oem and performance 2012 rxpx 260 parts
    By seadoo02xp in forum Sea Doo Classifieds
    Replies: 24
    Last Post: 10-24-2013, 01:29 PM
  4. 2012 RXPX 260 RS pump shoe seal problem help!
    By stiv in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-20-2013, 10:36 PM
  5. RXPX 260 issue
    By steffi69 in forum 4-Tec Performance
    Replies: 23
    Last Post: 09-29-2012, 06:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •