Results 1 to 4 of 4
  1. #1

    Join Date
    Aug 2012
    Location
    Garland, Tx
    Posts
    256
    +1
    12

    Ouch! problems this weekend already..

    So, Friday night, I replaced the water regulator on my 03 xpdi, and as soon as I get it on the water, I notice it will only build rpms to 6750.. not the usual 6850.. I lost 100 rpms somehow.. and i lost the low end grunt.. she would still get up and run, if on plane, but couldnt carve it up like usual, and just had no punch..
    Im not so sure the blame is all on the water regulator though.. I was riding about half throttle and it just quit. right there, just quit.
    after much ado.. getting towed by the fire department, while my friends were on shore 1/2 mile away with boats. (they said, they saw the sherriff and were having no part of it.. .. oh well, if they cant expect to ride, they shouldnt be expected to tow, right?)
    I pulled the fuel line and checked the flow on both sides of the filter, and hardly anything.. looked like an aquarium pump. damn!
    I guess thats what I get for trying to save a few bucks, and using an automotive filter inline.. I didnt do my due diligence in research, and I crapped my own pump..

    BUT, I did hit the biggest freaking wave!! and got some serious air! enough so that the yacht pulled around for a second pass, and everyone got out thier cameras..
    yeah.. that felt awesome.. he was spinning off 4 foot rollers 100-200 feet back..


  2. #2
    caliburn's Avatar
    Join Date
    Aug 2012
    Location
    Sister lakes Mich
    Posts
    531
    +1
    12
    what was wrong with the inline fuel filter? sorry for the ignorance? I just replaced my fuel lines as they were filled with crap and put a inline fuel filter on mine for added pertection.

  3. #3

    Join Date
    Aug 2012
    Location
    Garland, Tx
    Posts
    256
    +1
    12
    well, the seadoo inline assembly is the hoses + filter.. which I am not sure of its internal construction.. I didnt want to spend the 250-300 dollars for it, so I chopped the line and installed an inline filter I grabbed off the shelf from the auto parts store.. Some people have had success with that.. and I cant place total blame on the filter, however the filter I grabbed, was not designed for the 100 psi pump, and most likely did not have the internal construction to support.. flow rates, pressure, etc.. it *might* have had an effect on performance of a 10 year old pump...

    I chop it up to a combination of factors really though.. rough riding yesterday, 10 year old pump, incorrect parts, etc..
    in my experience with automotive fuel system failures, usually its a combination of changing conditions that will fail a pump, etc.. different fuel blends, temperatures, filters, age of components..

  4. +1 by:


  5. #4
    caliburn's Avatar
    Join Date
    Aug 2012
    Location
    Sister lakes Mich
    Posts
    531
    +1
    12
    Ok gothcha, with the injection lines under load/psi is what caused it to fail, not like the carb models that I own, you probobly been better off jetting a junk yard fuel filter assembly off a four banger, that sucks sorry to hear your pain.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. this weekends 250x problems!
    By tomrice in forum Kawasaki How To & FAQs
    Replies: 6
    Last Post: 10-29-2015, 03:01 PM
  2. 1st problem with my RXP this weekend...
    By wisconsin_quat in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-27-2009, 04:34 PM
  3. Well, I had a big problem with my Ski this Weekend...
    By LiquidDI in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-20-2007, 10:00 PM
  4. Yo Miketrin, my Lake of the Ozarks experience this weekend..
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-21-2005, 12:32 AM
  5. Got my rxp to 79 this weekend!
    By MikeTrin in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-10-2005, 03:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •