Results 1 to 5 of 5
  1. #1

    Kawasaki 300x, stage 1 problem

    I installed the riva stage 1 on my 300x and also new propeller, but after installed the waterbox, seems that my ski is slower. Checked all hoses & everthing. Any recomendation. getting frustrated. Thanks


  2. #2
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    What pitch is your prop?
    Do you have a speedbypass?
    What RPM are u running?
    Did you try to check your speed on GPS?

  3. #3
    dw_1's Avatar
    Join Date
    Jan 2012
    Location
    Sydney Australia
    Posts
    235
    +1
    4
    spot on questions

    the pitch of the prop is the 1st
    SCOM if its installed correct as sometimes the brown ECU wires or even the battery terminal wires not connected properly will make NOTHING happen (the SCOM should have been part of the stage 1)
    Hoses etc for leaks (what is your boost readign to on the guage now?)

  4. #4
    The prop is Solas 14/21.
    Do you thing that the waterbox and this prop could make backpressure?
    The scom is good

  5. #5
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129

    Kawasaki 300x, stage 1 problem

    Quote Originally Posted by Gian View Post
    The prop is Solas 14/21.
    Do you thing that the waterbox and this prop could make backpressure?
    The scom is good
    You most likely have a leak somewhere whats your speed on GPS whats your rpm whats your boost. Answer rhe above while your at wot.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. kawasaki 300x top speed problem
    By stiffla69 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 73
    Last Post: 09-04-2012, 04:33 PM
  2. RXP Stage 2 problem exhaust temp warning???
    By mstennes in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-07-2007, 08:47 AM
  3. Stage III problem
    By kawifan in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-29-2007, 10:39 AM
  4. 02 GPR stage III problems
    By rxp05 in forum Yamaha PWC Performance (2-stroke)
    Replies: 51
    Last Post: 05-08-2007, 10:44 PM
  5. Stage 1 problem
    By HoopsRXT in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-03-2006, 01:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •