Results 1 to 7 of 7
  1. #1

    1998 SLH700 Doesn't Rev

    I picked up this machine a few months ago, when I got it the piston had burned the ring land. The guy I bought it from included a good used piston and cylinder. I pulled the other cylinder even though it had good compression just to check it out. I honed both cylinders and put everything back together. It didn't want to idle when I put it in the water and it didn't want to accelerate. I pulled the carbs and went through everything. The guy that had it before me rebuilt the carbs and the fuel pump gasket was installed upside down so the two chambers weren't sealing well, he also had the low speed screws way off (one was out 1 1/2 turns and the other was out 2 1/2 turns) and the pop-off pressure was 25 PSI on both carbs. I reset everything and put it all back together. on the started and ran great, when I put it in the water it ran great at first. It ran as fast as my Kawasaki STX 900, but after I let off the throttle it idled ok but didn't want to rev. I played with it and was able to get past the bad spot and it runs great until I let it idle. Each time it idled I had to play with it to get it through the bad spot. For my bikes I have a carb chart that shows what part of the carb is used at particular throttle amounts and load, is there one for the Keihin carbs? I searched the forums but didn't find a lot of relative information or people that had the same issues I have, if anyone has some ideas let me know. Thanks.


  2. #2
    I was looking through the "Fuel Domestic Crabureted" thread and found the fuel delivery effect diagram. According to that it looks like the mid-range jet is clogged on one of the carbs, or at least it gives me a starting place to look.

  3. #3
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Also verify the regulator arm height. That will really mess things up if its not right. I just corrected that on one of my skis and the problems went away.

  4. #4
    Quote Originally Posted by BryanP View Post
    Also verify the regulator arm height. That will really mess things up if its not right. I just corrected that on one of my skis and the problems went away.
    OK, I'll check that also. I looked to see if the arm height looked off, but I didn't actually check it.

  5. #5
    Quote Originally Posted by BryanP View Post
    Also verify the regulator arm height. That will really mess things up if its not right. I just corrected that on one of my skis and the problems went away.
    My son Brandon rebuilt the engine over the winter, he's ten and this was the first PWC engine he built by himself. The engine had a bad repair job (epoxy) from when a rod bearing went bad. I terminated the crack with a drill bit and the TIG welded it. We put the engine back in to see if the seal was repair were the only problem, but it didn't completely fix it. I took the carbs off and took them apart to check everything, all the passages were clear, the pump is good I checked to see if it holds light pressure and vacuum. I checked the arm height and found the front carb was .085" and the rear carb was .045". Ill put it all back together after I adjust them and see what does!

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I bet it runs a lot better when you get the regulator arms set right.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,272
    Quote Originally Posted by LaserLTV View Post
    My son Brandon rebuilt the engine over the winter, he's ten and this was the first PWC engine he built by himself. ...
    I am impressed

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris Genesis 1200 (Carbureted) doesn't rev smoothly above idle
    By hookem91 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 04-14-2014, 03:14 PM
  2. 1998 Waverunner doesn't have any power at takeoff
    By BrandenG1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 03-06-2013, 10:34 PM
  3. 96 HX Hard Starting and Doesn't REV up very fast?
    By shkdwn387 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 03-22-2012, 08:14 PM
  4. Motor revs, doesn't go anywhere!
    By lockaby32 in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 07-13-2011, 09:42 AM
  5. 1998 gsx limited bogging down at 6000 revs
    By bamalam100 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-26-2010, 12:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •