Results 1 to 2 of 2
  1. #1

    Help with polaris mfd oval

    hi i cant get the display to work it reads 888888 and is slightly faded but if i disconnect it and reconnect it it display the time perfect but when mode button pressed (mfd woken up) display the same 888888 thing. any help would be great


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Try the MFD 'Reset' or Calibrate method outlined via my signature links, in the MFD section.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help with 750slt MFD
    By Desert Toad in forum Polaris PWC Performance
    Replies: 0
    Last Post: 07-02-2010, 12:14 AM
  2. Help With Polaris Sl750
    By Puerto-Rico in forum Polaris How To & FAQs
    Replies: 40
    Last Post: 06-19-2010, 04:25 PM
  3. I need help with Polaris 1200 head
    By fatboyztoyz in forum Polaris Open Discussion
    Replies: 4
    Last Post: 10-22-2009, 06:44 PM
  4. New to the Hulk need a little help with Polaris Virage
    By Tailfisher in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 05-13-2009, 01:23 PM
  5. need help with polaris slh 700
    By holcomb21 in forum Polaris PWC Performance
    Replies: 7
    Last Post: 06-08-2008, 03:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •