Results 1 to 3 of 3

Thread: Pump

  1. #1
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,898
    +1
    506

    Pump

    Removed my pump yesterday to change out the stock impeller to a Solas and my wear ring just falls out! Is this normal of course the temp was like 40 degrees out. Even today temp 56 degrees wear ring still loose in pump but not like when it was colder. Only 11 hours on the ski since new


  2. #2
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,764
    +1
    29

    Thumbs up

    yes its ok..I`ve changed impellors when the ring comes right out and flipped it for the people so as not to geta new one yet.

  3. #3
    oklagp1200r's Avatar
    Join Date
    Nov 2005
    Location
    Newcastle, Oklahoma
    Posts
    2,898
    +1
    506
    Yea thanks that what I was thinking also! My freind that helped me change the impeller out said once its bolted back in it places presher against wear ring somewhat to hold it in place also!
    COOL!
    Thanks Hoss!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Bilge Pump install
    By Vern in forum 4-Tec Performance
    Replies: 14
    Last Post: 08-27-2014, 10:04 AM
  2. Skat-trak pump mod
    By nitro rxp in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-04-2005, 09:00 PM
  3. PUMP MOD
    By peteshauling in forum 4-Tec Performance
    Replies: 20
    Last Post: 06-01-2005, 10:08 AM
  4. New Magnum pumps from Skat Trak
    By Green Hulk in forum 4-Tec Performance
    Replies: 34
    Last Post: 05-12-2005, 08:56 PM
  5. PUMP WEDGE
    By RXPNJ in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-10-2005, 09:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •