Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    tattoobrad22's Avatar
    Join Date
    Aug 2012
    Location
    Kennesaw, GA
    Posts
    22
    +1
    1

    97 GTX 787 loud clicking

    So I got my coil in today and installed it. I started the ski for the first time and it ran great for about 10 seconds then stalled. I went to restart it and it will turn over but there is a real loud and fast clicking sound while cranking and it won't start. The problem is all I know about the history of the ski is that it has 95 hours and the starter has been replaced (owners thought that was why it wouldn't start, turned out to be the dess post and coil). You guys have any idea what the problem could be?


  2. #2
    1 - Broken pickup coil bracket under magneto cover?
    2 - rotary valve or gear?

    starter bendix?
    Broken piston?
    Rod bearing?

  3. #3
    Dixieboy Dixieboy's Avatar
    Join Date
    Jan 2008
    Location
    Millington, Tn
    Posts
    62
    +1
    1
    Do a quick compression check before trying to start again. The cylinders should read near the same

  4. #4
    tattoobrad22's Avatar
    Join Date
    Aug 2012
    Location
    Kennesaw, GA
    Posts
    22
    +1
    1
    Here is a video of it cranking without the plugs in. Maybe you can hear it.
    http://www.youtube.com/watch?nomobile=1&v=D6ZqVdRWZHo

  5. #5
    caliburn's Avatar
    Join Date
    Aug 2012
    Location
    Sister lakes Mich
    Posts
    531
    +1
    12
    I could not hear the clicking that your talking about, explain it alittle better and where is it coming from can you tell, do you have any spark?, I am sure this is not it but a clicking sound can be caused by a bad spark plug line arcing on the motor and such

  6. #6
    tattoobrad22's Avatar
    Join Date
    Aug 2012
    Location
    Kennesaw, GA
    Posts
    22
    +1
    1
    Spark is really good, very strong and blue on both plugs. It's hard to explain the sound exactly, it's like a very fast and constant metal on metal click, grind or very light knock that sounds like its coming from the starter/ intake side of the motor. It doesn't sound like the crank bearings or anything. I pulled the starter thinking maybe the starter gear was stuck, but I put it on the bench and it tested fine, and the flywheel teeth look real good. I don't know a whole lot about these 2 strokes, I'm used to 4 stroke dirt bikes and atv's

  7. #7
    Quote Originally Posted by tattoobrad22 View Post
    It's hard to explain the sound exactly, it's like a very fast and constant metal on metal click, grind or very light knock that sounds like its coming from the starter/ intake side of the motor.
    There is a gear driven round metal rotary valve that sits right behind the carb manifold cover..

    Remove the carbs and round manifold cover - inspect for damage

  8. +1 by:


  9. #8
    tattoobrad22's Avatar
    Join Date
    Aug 2012
    Location
    Kennesaw, GA
    Posts
    22
    +1
    1
    Quote Originally Posted by KYHI View Post
    There is a gear driven round metal rotary valve that sits right behind the carb manifold cover..

    Remove the carbs and round manifold cover - inspect for damage
    thanks for the tip, took off the carbs and cranked the motor by hand and that rotary valve won't spin. I can order the parts and replace the gear, but what could have caused the gear to strip out?

  10. #9
    This is where it gets tricky - did the rotary valve splines strip out or did the brass gear that drives the rotary shaft stripe out?

    You can pull just the rotary shaft out - but depending on the type of damage done, you may have to split the crankcase..
    If the brass gear striped out - there will be brass wedged into the crank gear that would need to be cleaned off - that crank gear is also known to move out of alignment on the crankshaft..
    So bad gets even worse..

  11. #10
    tattoobrad22's Avatar
    Join Date
    Aug 2012
    Location
    Kennesaw, GA
    Posts
    22
    +1
    1
    Haven't got that far yet, I going to take the shaft out today. But when I spin the motor the valve will move about a 1/8" forward then move back everytime.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS FS parting out a 97 gtx 787
    By snoproken in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 09-21-2011, 09:17 PM
  2. Rev limit for 97 gtx 787
    By carguy89 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 07-09-2011, 02:52 PM
  3. 97 GTX 787 Surges when warm
    By GarageDetailer in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-29-2010, 07:39 AM
  4. WTB: Looking for a good working jet pump for a 97 GTX 787
    By awague2 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 08-06-2008, 12:57 PM
  5. 97 GTX 787 engine shuts off (all power) over 4000 RPM
    By markrvp in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-24-2008, 06:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •