Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    help 06 seadoo rxp blown supercharger

    hey I'm new to site , but we pull my buddy supercharger apart on his rxp 06 and it was destroyed clutch washer gone and the wheel was eating the front housing , bought a used supercharger complete off line with a riva rebuild kit in it , but now its not building boost like it should and ski only goes like 48 mph what else could have went wrong ski has 160 hr on it


  2. #2
    To much is never enough Badvgood's Avatar
    Join Date
    Jun 2012
    Posts
    699
    +1
    31
    Did you strip and clean the engine from all the bits of the old super charger washers?? You need to or bang goes the engine soon....

    Sounds like the clutch slip on the new supercharger may be set incorrectly and is slipping to soon and not letting boost build up.

  3. #3
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Quote Originally Posted by lilsam View Post
    hey I'm new to site , but we pull my buddy supercharger apart on his rxp 06 and it was destroyed clutch washer gone and the wheel was eating the front housing , bought a used supercharger complete off line with a riva rebuild kit in it , but now its not building boost like it should and ski only goes like 48 mph what else could have went wrong ski has 160 hr on it
    Sounds like whoever rebuilt the charger did it incorrectly if he actually rebuilt it. Sounds like it crushed a bearing causing the wheel to touch. Problem is now you will have to pull the motor and clean out the inside make sure to inspect the timing chain for any nicks. all you need is to clean it out put it back together and then pop the chain and float some valves. make sure you inspect the timing chain also. Good luck.Where are you located?

  4. #4
    im in michigan , he say he let the a dealer rebuild it , so what r u guys thinking new clutch washers,

  5. #5
    is it a way to set how soon the clutch slips

  6. #6
    As stated before it may be more than the new charger. You may have gotten pieces of the old washers and possible damaged bearings into the motor. May have done internal damage to the engine bearings.

  7. #7
    it just seem like i would hear something like a knock or rattle or ticking , but i will b pulling engine just wanna no what to look for

  8. #8
    drugnas's Avatar
    Join Date
    Dec 2014
    Location
    GREECE
    Posts
    26
    +1
    1
    Pleeeease help me,I bought rxt 215 next summer with 130hours and now I have 147hours..I dont have any problem.In this winter im in rebuilt mood because the summer is very near,you now what I mean...Im doing rebuilt sc with oem kit and I saw the old one has a riva washers.When im going to change oil I found in the filter between the papers very small pieces of steel...after I open the oil pump and I found again bigger pieces and the rotor has many hits and stripes,I collected all the pieces near to a magnet and I understood it was ceramic pieces..the small stainer in the pump has also pieces but its ok withno damage..I want your opinion.I dont know the history of ski..the only thing that I know is im the third byer.....Click image for larger version. 

Name:	IMG_20150311_180840.jpg 
Views:	116 
Size:	96.0 KB 
ID:	353308 Click image for larger version. 

Name:	IMG_20150311_182525.jpg 
Views:	71 
Size:	42.6 KB 
ID:	353309

  9. #9
    drugnas's Avatar
    Join Date
    Dec 2014
    Location
    GREECE
    Posts
    26
    +1
    1
    Click image for larger version. 

Name:	IMG_20150311_182555.jpg 
Views:	64 
Size:	50.6 KB 
ID:	353311Click image for larger version. 

Name:	IMG_20150311_131847.jpg 
Views:	65 
Size:	112.5 KB 
ID:	353312oClick image for larger version. 

Name:	IMG_20150311_184451.jpg 
Views:	72 
Size:	41.0 KB 
ID:	353313Click image for larger version. 

Name:	IMG_20150311_180747.jpg 
Views:	48 
Size:	71.5 KB 
ID:	353314

  10. #10
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    OOOOOOOOH man... Its recommended by everyone whos to see those pics that you must pull the motor, split the cases and clean it out...ALL of , even the oil screen in the front oil pump. OR you could be a schister and fix whats broke and pass it on? (not cool) it sucks but its gotta be done.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 05-21-2013, 02:38 AM
  2. Replies: 9
    Last Post: 04-14-2013, 08:43 PM
  3. 06 seadoo rxp T400-500 any help appreciated
    By durawood in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-08-2010, 07:28 PM
  4. help 06 seadoo gti
    By jmodc919 in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-06-2008, 11:23 PM
  5. seadoo RXP non supercharged?
    By Bastiaan maarten Bok in forum 4-Tec Performance
    Replies: 0
    Last Post: 10-23-2007, 09:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •