Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1

    Steering is hard now, help

    Read 2-3 posts about this but no response on how got fixed. I wash my ski very good after every use. I did not move my ski for a month because took it apart to replace the prop (did not have time to reinstall the pump) and now the steering in my 2011 300X is very hard and not fun. Checked for steering recall and everything is fine. Any ideas?

    moved everyting in the pump around and seems fine and loose. Have used the ski twice and perfect but very hard steering.


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,163
    +1
    602
    Remove cable from nozzle an see if it's still hstd , sounds like cable is attached wrong

  3. #3
    Will do

  4. #4
    finally did it and nothing. Disconected the cable from nozzle and still the steering is hard. Checked from begining to end and lubed it and still nothing. Just found a Fu.. sunblock bottle by the steering and removed it but nothing changed.

  5. #5
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129

    Steering is hard now, help

    Quote Originally Posted by jwaked View Post
    finally did it and nothing. Disconected the cable from nozzle and still the steering is hard. Checked from begining to end and lubed it and still nothing. Just found a Fu.. sunblock bottle by the steering and removed it but nothing changed.
    The assy is stiff or the nozel or cable. Did u check where it connects on the steering assy to make sure there no wires or tubes binding on it.

  6. #6
    The nozzle is fine and loose. Must be the cable. Everything looks fine. I guess Im going to have to take everything apart to see if the cable is rusted.

  7. #7
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129

    Steering is hard now, help

    Quote Originally Posted by jwaked View Post
    The nozzle is fine and loose. Must be the cable. Everything looks fine. I guess Im going to have to take everything apart to see if the cable is rusted.
    Did u do what I said above ? Disconnect the steering from the cable ? So you can diagnose both there was a recall on the cable did you have yours inspected.

  8. #8
    Yes recall inspected and its fine. I disconnected the cable from nozzle, but not the cable from steering. Was trying the easy stuff first because ddd not want to take the steering apart. Any idea on how to disconnect the cable from steering without taking everything apart to reach it?

  9. #9
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129

    Steering is hard now, help

    You don't take anything appart open hood pull out ecu bracket reach up and unclip if from steering same way as the nozel. That's why I said inspect in there to make sure it's not binding on any cables or hoses.

  10. #10
    Cool, will do tonight. Thanks man

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. leaking intercooler and now ski is throwing codes- HELP!
    By codymouse54321 in forum 4-Tec Performance
    Replies: 12
    Last Post: 06-02-2011, 07:56 PM
  2. A bit confused about where water is coming in... Help!
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 18
    Last Post: 04-23-2007, 12:38 PM
  3. What is this? Please Help!
    By holdnon72 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 03-25-2007, 08:28 AM
  4. What now? HELP!
    By GeoRXT in forum Yamaha Open Discussion
    Replies: 9
    Last Post: 03-12-2007, 08:47 AM
  5. I guess Riva is hard at work...
    By Vman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 01-25-2007, 07:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •