Results 1 to 6 of 6
  1. #1

    Join Date
    Sep 2012
    Location
    Salisbury NC
    Posts
    3

    Intake Grate Problems

    Hello...

    I am having some issues with my ski. I am slowly upgrading things on my 2006 Sea Doo RXT, and noticed that my stock intake grate was broken. So, I went on to this site and ordered the Riva Grate and installed it according to the instructions provided with it. Well, everything was running great, I am running it on a fresh water lake, water was choppy...next thing I know is that it doesnt have the take-off like it did. I get back to shore, park it for about 30 mins and then I notice that the rear end is sitting really low in the water. I go to it and pop the seat and see that my ski is sinking. I back the trailer down and put it on...once out of the water, I see water pouring out of the forward screw hole of the intake grate and the grate is missing! (fastest $150 I have spent, only in water one weekend)

    I dont remember hitting anything, and there is no major trailing damage or leading damage at that! So, I guess my questions are...what is the best way to fix this problem (hull repair, replacement of new grate), and has this ever happened to anyone before?


  2. #2
    yems's Avatar
    Join Date
    Apr 2012
    Location
    Tauranga, New Zealand
    Posts
    45
    That would scare the bejesus out of me. Did u threadlock all the bolts back in?

  3. #3
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    First of all Welcome to the Hulk!

    When you installed the Riva grate did you torque each bolt down to 22-24 Ft-Lbs and use Blue Loctite 243? Did you let it set for 24 hours before you used the ski?


  4. #4

    Join Date
    Sep 2012
    Location
    Salisbury NC
    Posts
    3
    I did torque the bolts and use the locktite....I let it set up for a week....it doesnt make much sense..lol...it is like it was ripped out without damaging anything around it except the nut plates that attached the grate to the hull.

  5. #5
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    WOW!

    Are the bolt inserts ripped out or damaged? Take a few pictures and post them up......

    This is very puzzling for sure...........

  6. #6

    Join Date
    Sep 2012
    Location
    Salisbury NC
    Posts
    3
    I am sorry for the delay, I have been out of town on official orders...but I will post pics this weekend. I have not even had the time to really get down and dirty with it. I hope with the picks and your advice I can prevent this from happening again!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. R&D Intake Grate Problem
    By beachbum0286 in forum 4-Tec Performance
    Replies: 26
    Last Post: 09-08-2008, 11:54 AM
  2. FZR SHO Intake Grate Problems ? ? ?
    By QBNKID in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 08-26-2008, 03:13 PM
  3. intake grate problem
    By salerngo47 in forum 4-Tec Performance
    Replies: 15
    Last Post: 07-16-2008, 01:10 AM
  4. R&D Intake Grate Problems.. What Grate to Buy?
    By stepjl in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 09-17-2007, 05:12 AM
  5. Intake grate problems!!!
    By GeoRXT in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-20-2006, 09:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •