Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: 95 xp issue

  1. #1

    95 xp issue

    I have a 95 xp that had a 717 motor that got wrecked (previous owner sunk it in salt water and never flushed it). I had a good 587 motor from a 93 gtx,the gtx was in rough shape so pulled the motor and put it in the xp.I used the electronics box from the 717,and the motor fired and ran fine on the hose. Took it out for a ride and for the first few minutes it would not get above 3500 rpm with the throttle wide open. If I let off the gas and got back into it a bunch of times it started to come around,got it moving decent at about 5700 rpm.Things were good until I let off then the process started again of working the gas.Any Ideas what could be causing this?

    I'm a real noob at these things,I got these xps for free one had the bad motor and the other had a brand new 717 motor that runs great.I'm new here so any help would be great and here is a picture of my new toys
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	2012-09-02_18-54-32_796.jpg 
Views:	93 
Size:	81.2 KB 
ID:	282865  


  2. #2
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    Probably over propped. Try using the impeller from the GTX. Could also be fuel starvation which led to the original engines demise. Clogged up fuel switch.

  3. #3
    The original motor got filled with salt water and left to turn into a block of salt.I cleaned the fuel tank,replaced all the fuel lines and filters.Running 50:1 pre mix. I was not sure if the prop between the big gtx and the xp would be different,I guess I could swap them.Maybe the 587 cant handle the xp impeller and pump?It could still be a fuel issue though.Thanks

  4. #4
    It's real easy to swap those fuel lines so double check that. The carbs have internal filters that clog up and you need to know that they are clean. No the 587 can't pull the 717 prop there is a 20-30 hp difference there.

  5. #5
    I replaced all the fuel lines so I guess I will make sure the carbs are good.Will the gtx prop change over to the xp?If not what kind of prop should I get?

  6. #6
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    Yes, impellers will swap out, they are both 140mm.

  7. #7
    So they are both the same size then (140mm) but different pitch right?

  8. #8
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    Correct.

  9. #9
    Are the pump housings the same just with a different prop.Can I just swap the whole gtx assembly over?

  10. #10
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    I can't remember. I think the older one is slightly different.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '95 xp no start issue
    By gorilla03 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 04-05-2008, 05:37 PM
  2. 95 xp running bad
    By pappastratos in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-22-2007, 02:54 PM
  3. 95 xp question
    By Blackhardt in forum 2-Stroke Performance
    Replies: 4
    Last Post: 04-26-2007, 09:55 AM
  4. 95 xp fuel line clamps
    By Blackhardt in forum 2-Stroke Performance
    Replies: 3
    Last Post: 01-23-2007, 08:39 PM
  5. 95 xp pump and nozzle
    By Blackhardt in forum 2-Stroke Performance
    Replies: 10
    Last Post: 01-21-2007, 09:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •