Results 1 to 9 of 9

Thread: 96 gsx

  1. #1

    Join Date
    May 2010
    Location
    Savannah, GA
    Posts
    157
    +1
    1

    96 gsx

    It has been running well but now will not go over 3200 rpms. It will if turn it off then start it and go full throttle but it will drop back to 32-3400.

    I have done rebuilt carb new plugs and wires no change.

    Any pointers


  2. #2
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Check and clean the FUEL selector valve........

  3. #3

    Join Date
    May 2010
    Location
    Savannah, GA
    Posts
    157
    +1
    1
    I have replaces last year. As it would not run on the primary selection. I have replaced fule lines last year to. But i will take it apart and clean it.

  4. #4

    Join Date
    May 2010
    Location
    Savannah, GA
    Posts
    157
    +1
    1
    All clean still no luck. Does this in water and out.
    check system for air leaks none i can see. Fuel lines I have are clear so i can see the fuel ans no air in.

  5. #5

    Join Date
    May 2010
    Location
    Savannah, GA
    Posts
    157
    +1
    1
    Really can use some help here. Took everything a part. Fuel lines Srebrenica good switch is clean carbs are clean. Start engine I can give full gas it runs great for like 10 sec. Then drops too 3000k rams. Will not go back up unless u kill engine and restart will do the same thine. Please help....?

  6. #6
    Paradise rider aruba yamaha's Avatar
    Join Date
    Dec 2007
    Location
    Aruba
    Posts
    305
    +1
    2
    You stated that you replaced plugs and wiring. So I assume the sparkplug wires. Did you changed them with coppercore cables? If you didn't change them for coppercore and see how she runs. The problem you say you have can be a carb problem or electricial.
    Let us know what you found.

  7. #7
    Paradise rider aruba yamaha's Avatar
    Join Date
    Dec 2007
    Location
    Aruba
    Posts
    305
    +1
    2
    Also check the airflow TO the fueltank. You may have a clogged checkvalve. It will starve the fuel to the engine. I had it one time that I could swear it was the carbs. Resulted the check valve was clogged.

  8. #8
    surferd15's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, FL
    Posts
    1,142
    +1
    83
    Could be your rectifier, open front electrical box and look for the rectifier (silver square box has one red and three yellow wires) disconnect red and try it.

  9. +1 by:


  10. #9

    Join Date
    May 2010
    Location
    Savannah, GA
    Posts
    157
    +1
    1
    Quote Originally Posted by surferd15 View Post
    Could be your rectifier, open front electrical box and look for the rectifier (silver square box has one red and three yellow wires) disconnect red and try it.
    It the rectifier. Pull red runs great. What does the rectifier do? Can i run it with red unplugged?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ext pump for 96 gsx
    By RiverRat19405 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 09-12-2007, 07:39 AM
  2. 96 gsx fuel pump
    By RiverRat19405 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-28-2007, 09:08 AM
  3. working on 96 gsx 800
    By RiverRat19405 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-24-2007, 08:49 PM
  4. '96 GSX..Has spark..has fuel..has compression..won't start
    By HeyUvaVT in forum 2-Stroke Performance
    Replies: 3
    Last Post: 07-14-2007, 09:58 AM
  5. 96 GSX Throttle Cable Stuck
    By Cyclone268 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-13-2007, 09:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •