Results 1 to 4 of 4
  1. #1

    impeller scraping

    I noticed when trying to start my 96 raider 1100 there was a metal sound in the back and it would not start. I got under the ski and my friend cranked it. The impeller was hitting and sparking. What does this mean? I have had a stalling issue where it dies if i let go of the throttle. I wonder if this could be the problem. What needs to be done and why is it scraping? Thanks


  2. #2
    Flying Scotsman's Avatar
    Join Date
    May 2006
    Location
    IllINOIS
    Posts
    6,514
    +1
    4
    Could be a bent impeller but most likely its the wear ring.Crud gets in between the sleeve and the body.
    Find a goodused wear ring on ebay or buy a new one.

  3. #3
    RIVERA RACING RIVERA RACING's Avatar
    Join Date
    Jan 2010
    Location
    New Jersey
    Posts
    1,578
    +1
    87
    repleace wear ring and prop....
    Quote Originally Posted by philski3 View Post
    I noticed when trying to start my 96 raider 1100 there was a metal sound in the back and it would not start. I got under the ski and my friend cranked it. The impeller was hitting and sparking. What does this mean? I have had a stalling issue where it dies if i let go of the throttle. I wonder if this could be the problem. What needs to be done and why is it scraping? Thanks

  4. #4
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    wear ring swollen.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. scraping/rattle after impeller change
    By Tbarile in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 10-10-2016, 08:10 AM
  2. What pitch impeller
    By Turbo Todd in forum 4-Tec Performance
    Replies: 10
    Last Post: 11-21-2008, 10:55 AM
  3. Impeller Scraping Normal?
    By thomslik in forum Polaris Open Discussion
    Replies: 11
    Last Post: 07-17-2007, 10:24 AM
  4. Replies: 3
    Last Post: 05-06-2005, 02:01 PM
  5. SC impeller
    By shhr in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-02-2005, 09:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •