Results 1 to 6 of 6
  1. #1

    Join Date
    Aug 2012
    Location
    United States
    Posts
    95
    +1
    6

    spark plug issue?...or worse?



  2. #2

    Join Date
    Aug 2012
    Location
    United States
    Posts
    95
    +1
    6
    my ski is revving on its own for a second or two....then idle....then a quick Rev...and so on. I noticed it today. it was boggling a little; so I unhooked my display because the lo-fuel light kept coming on since I need a new float in the fuel tank.....once if did that I noticed this. if I am In a no wake zone it is Rev....idle...Rev idle....it doesn't affect my speed........
    then when rinsing everything off at the end of the day; I had it out of the water and noticed it when I was running it with the hose. I thought maybe the spark plugs......
    I also added some fuel additive to help clean the carbs ....before I noticed the problem...could that cause this?

    on the other side of things.....I took my 4 year old "jet ski fishing"...we caught croakers-sea bass-oyster crackers-and a 3' sand bar shark....pretty fun!

  3. #3

    Join Date
    Aug 2012
    Location
    United States
    Posts
    95
    +1
    6
    to clarify.....the bogging is fixed. now I have the over reviving issue...not both together. ... the revving is like a 20 to 30% Rev...not a dangerous ...buck me off the ski kind of Rev.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Quote Originally Posted by rwolhar View Post
    my ski is revving on its own for a second or two....then idle....then a quick Rev...and so on. I noticed it today. it was boggling a little; so I unhooked my display because the lo-fuel light kept coming on since I need a new float in the fuel tank.....once if did that I noticed this. if I am In a no wake zone it is Rev....idle...Rev idle....it doesn't affect my speed........
    then when rinsing everything off at the end of the day; I had it out of the water and noticed it when I was running it with the hose. I thought maybe the spark plugs......

    I also added some fuel additive to help clean the carbs ....before I noticed the problem...could that cause this?...
    If the carbs been cleaning, then no fuel additive is going to do the job. Remove them and properly rebuild the carburetors with genuine OEM rebuild kits.

    Which year and model watercraft are we talking about?

  5. #5

    Join Date
    Aug 2012
    Location
    United States
    Posts
    95
    +1
    6
    1996......sl900. I hope it is the spark plugs Bc I can fix that....

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Quote Originally Posted by rwolhar View Post
    1996......sl900.

    I hope it is the spark plugs Bc I can fix that....
    What you are comfortable doing has little relationship to what the watercraft might need.

    Read up on how these machines work, and what the common issues and maintenance items are.

    Make sure you have the correct NGK spark plugs installed, of course.

    Then work through the diagnostics and maintenance stuff.

    I suggest NOT riding it until you have all the problems sorted out. It is very possible to damage the engine if it is ridden with fuel system or carburetor problems.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fouled Spark plugs issue
    By eVolution54 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-21-2011, 08:39 PM
  2. 2006 rxp spark plug issues
    By skigolfnut in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-03-2011, 03:48 PM
  3. Spark Plug Issue?
    By gprsh924 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-20-2009, 05:07 AM
  4. Spark plug issue.........last post
    By colin_red250x in forum Kawasaki PWC Performance (4-stroke)
    Replies: 18
    Last Post: 08-07-2009, 01:52 PM
  5. Spark plug issues
    By mooneyb91084 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 43
    Last Post: 08-17-2007, 08:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •