Results 1 to 3 of 3
  1. #1

    Need help analyzing a problem

    When I attempt to start the jet ski nothing happens but a clicking sound. It has a new sealed battery after sitting for over a year. I traced the clicking sound to the front of the ski. It's coming from the MPEM that the red(+) cable off the battery attaches to. Looking at the diagram in the store there is a starter relay. Do they go out or is my problem somewhere else? Thanks
    Last edited by vduzin12; 09-14-2012 at 12:09 PM.

  2. #2
    R-Doo's Avatar
    Join Date
    Sep 2006
    It's the starter relay. Very common problem. I've had to replace mine on my 06 RXT.
    Quick and easy fix.

  3. #3
    thanks, thats where I"ll start.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wierd Starter relay problem....NEED HELP???
    By jitees in forum 4-Tec Performance
    Replies: 18
    Last Post: 03-20-2010, 06:19 PM
  2. Need help! '08 RXPX problem
    By DCoog in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-28-2009, 09:13 PM
  3. I Need Help Diagnosing A Problem..
    By mikefeliz7 in forum 2-Stroke Performance
    Replies: 22
    Last Post: 02-17-2009, 06:29 PM
  4. Need help with Spark Problem on a 89 WR500
    By vinnie333 in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 06-24-2008, 06:35 AM
  5. Need help with bucking problem
    By jgustman in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 01-09-2007, 05:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts