Results 1 to 4 of 4
  1. #1

    Engine warning light came on after going over a wake?

    I have a 2011 RXT 260 IS and yesterday I took it out and after I went over a wake, the beep came on then the light. The ski lost power for a second till it came to a stop then it went on fine with the light on. I checked the manual today and it said it means either limp home mode, which I would guess means the computer limits the engine so you do not cause more damage to the engine. Or it means minor engine fault, or just some maintenance required. So i used it for the rest of the day, because it seemed like it was running perfectly fine with no issues. Tied it up to my boat that was beached and it sat for an hour, then when I got back on, the light was gone and did not come back on after I tied it up. Then we took it out again after about 2 hours, then after 20 minutes of riding, it came back on again. I checked the oil and coolant and they were all full just to make sure. I am going to take it to the dealer to get this checked out for sure, but what is this and what happened?

    Thanks guys,


  2. #2
    Full Throttle or Broke!!! UNSANE's Avatar
    Join Date
    Aug 2008
    Location
    Orlando
    Posts
    721
    +1
    82
    Is the throttle response erratic? Is so, try the following:
    While stopped (beached or on trailer) raise the deck all the way and remove the front storage bucket. Now look into the area underneath the gauge cluster and you will see the gray connecting block. On our skis it just sort of hangs there. Reach in and squeeze the connector together. You may feel the very faintest of a "click".

    I have to do this every once in a while.

    Try that and see.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_0077.jpg 
Views:	117 
Size:	68.0 KB 
ID:	283294  

  3. #3
    Ok, thanks. I will try this and see if it works

  4. #4
    jkflow's Avatar
    Join Date
    Jun 2007
    Location
    Tampa, FL
    Posts
    77
    +1
    4
    Quote Originally Posted by UNSANE View Post
    Is the throttle response erratic? Is so, try the following:
    While stopped (beached or on trailer) raise the deck all the way and remove the front storage bucket. Now look into the area underneath the gauge cluster and you will see the gray connecting block. On our skis it just sort of hangs there. Reach in and squeeze the connector together. You may feel the very faintest of a "click".

    I have to do this every once in a while.

    Try that and see.
    Why not secure with a plastic zip tie? Easy to cut if needed but it will prevent it front coming apart.
    Never had this issue on mine but good to know.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rxp 2004 engine warning light after rebuild
    By yoghurtshotgun in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-12-2012, 10:44 AM
  2. Oil Warning Light came on... oil level was fine.
    By smbstyle in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 07-26-2009, 07:34 PM
  3. Installed the Stage1 and my check enging light came on...
    By Denali44 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 04-16-2006, 11:04 AM
  4. MAINTANCE LIGHT CAME ON AT 69 HRS
    By macattack in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-02-2005, 08:24 AM
  5. check engine light came on when i went down to sea level
    By macattack in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-01-2005, 02:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •