Results 1 to 5 of 5
  1. #1

    97 Wave Venture Idling High after Switching To Pre Mix!!

    Alright guys I need a little help, I'm new to the site but have done a little searching and have come up with nothing. I've got a 97 wave venture 1100 just switched it over to premix and when i start it now the ski begins at a low idle and then gets higher and higher, def not where it should be..

    I wanted to know if anyone else has experienced this and had to adjust the idle screw after switching to premix or am I missing something here. I have double and triple checked all of the wires and hoses I think I messed with. Thanks in advance...


  2. #2
    slothman's Avatar
    Join Date
    May 2011
    Location
    Hell
    Posts
    731
    +1
    30
    Quote Originally Posted by Scobee1kenobi View Post
    Alright guys I need a little help, I'm new to the site but have done a little searching and have come up with nothing. I've got a 97 wave venture 1100 just switched it over to premix and when i start it now the ski begins at a low idle and then gets higher and higher, def not where it should be..

    I wanted to know if anyone else has experienced this and had to adjust the idle screw after switching to premix or am I missing something here. I have double and triple checked all of the wires and hoses I think I messed with. Thanks in advance...
    Did you mess with the carbs recently ? What about the throttle cable ?

  3. #3
    Nope, haven't touched the carbs and the throttle cable I checked for binding or tightness... Nothing

  4. #4
    slothman's Avatar
    Join Date
    May 2011
    Location
    Hell
    Posts
    731
    +1
    30
    could be a vac leak, triple check every single hose.

  5. #5
    Thanks man, I will. It's driving me nuts, it idled perfect prior to switching to pre mix

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wave Venture Idle Problems after swtiching to Pre Mix!!
    By Scobee1kenobi in forum Yamaha Old School Skis
    Replies: 11
    Last Post: 09-24-2012, 08:27 PM
  2. Idle adjustment screw on 97 wave venture 1100
    By sortsol in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-11-2011, 09:57 AM
  3. 97' Wave Venture cutting out at 1/2 to WOT.
    By Durronz in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-08-2011, 11:16 AM
  4. Steps for Switching to Pre-Mix?
    By kdxcookie in forum Yamaha Old School Skis
    Replies: 9
    Last Post: 12-30-2008, 09:24 PM
  5. Switched to pre mix 96' ZXI 750
    By TX21 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 04-17-2008, 08:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •