Results 1 to 3 of 3
  1. #1

    xl1200 steering cable slipping

    1999 xl1200ltd - I disassembled the thru-hull connector for the steering cable without paying sufficient attention to details. Now cable slips during use at power.

    I recall a rubber grommet and a washer inside the plastic threaded cap on the thru-hull fitting. I added several washers to shim the grommet with no success. I believe I tightened the plastic nut to the point that I risk stripping the threads.

    Did I leave out a plastic split ring collar or does that go somewhere else?

    Thanks again.

  2. #2
    did you mount the cable up front in the grooved joint when clamping it down?

  3. #3
    Yes, the front end is solidly clamped and not moving. I have just a 1/4" or less of slip thru the rear clamp/thru-hull fitting.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS 98 xl1200 steering cable
    By nick34 in forum Yamaha Classifieds
    Replies: 3
    Last Post: 12-05-2010, 08:17 AM
  2. WTB Yamaha 1999 XL1200 Steering Cable
    By MNAPR in forum Yamaha Classifieds
    Replies: 0
    Last Post: 08-04-2008, 12:19 AM
  3. Extending the stock trim and steering cable for 2" exte
    By Insanediego Joe in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 11-01-2007, 05:55 PM
  4. Steering cable and stock tube ....
    By Flyer in forum 4-Tec Performance
    Replies: 7
    Last Post: 02-26-2006, 12:31 PM
  5. Steering Cable Tip
    By 1FastTrespiper in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-26-2005, 08:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts