Results 1 to 3 of 3
  1. #1

    95 yamaha ra 1100 no spark on either plug

    The first day I bought this ski it died on me and ever since its not getting any spark on either cylinder. The day it died it was out of oil when I checked it. Could this cause a problem like this.

    I already replaced the cdi first and then the stator. But same problem, no spark at all.
    All have good compression and getting gas just no spark..any help would be greatly appreciated.


  2. #2
    Join Date
    Jan 2010
    New Jersey
    check the fuse....

  3. #3
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Madison, WI, USA
    Do you have a service manual? Thats my first piece of advise.
    Check the stop switch and the thermo switch.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 ZXI 1100 no spark on any plugs.
    By ZXI1100_1997 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-18-2012, 01:12 PM
  2. 98 Kawasaki 1100 STX-Spark plugs
    By CaptPete319 in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 03-29-2010, 09:28 AM
  3. WTB Genuine Yamaha GP1300R Number 2 Spark Plug Lead
    By D88827 in forum Yamaha Classifieds
    Replies: 1
    Last Post: 03-14-2010, 07:12 PM
  4. 04 Yamaha FX Cruiser HO Spark Plugs
    By milcouch in forum Yamaha PWC Performance (4-stroke)
    Replies: 8
    Last Post: 08-03-2009, 08:57 AM
  5. 89 Yamaha WR500 doesn't spark continuously
    By vinnie333 in forum Yamaha Old School Skis
    Replies: 9
    Last Post: 06-27-2008, 04:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts