Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    Any Problems with a RXP-X 260 ?

    Hello,

    Is anywhere here, how has some problems with the new RXP-X 260 ?

    I pickt up my new Ski last Friday, and my trim gauge is spinning up and down.....


    Best regards


  2. #2

    Join Date
    Jul 2012
    Location
    Ontario canada
    Posts
    10
    My fuel sensor went bad in the first 3 hours
    Other than that love this thing just want more top end

  3. #3
    okay, did your dealer change the fuel sensor ? if my fuel tank is totally full, i missing at the fuel gauge 1 line....

  4. #4
    steffi69's Avatar
    Join Date
    Jul 2010
    Location
    calvi,corse
    Posts
    240
    52h on it with no problems

  5. #5
    Masterz's Avatar
    Join Date
    Jun 2008
    Location
    Watson, LA
    Posts
    219
    +1
    1
    50 hrs here... Lovin it!

  6. #6
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    Quote Originally Posted by RXP-X 2011 View Post
    okay, did your dealer change the fuel sensor ? if my fuel tank is totally full, i missing at the fuel gauge 1 line....
    Everyone is having the same issue ( i think ), the gauge is not right...
    When it says 1/2 fuel, I have approx 3/4... LOL

  7. #7
    Martin RXT-X's Avatar
    Join Date
    Jul 2011
    Location
    Kemah Tx
    Posts
    665
    +1
    89
    Supercharger bearing failure. At 72 hrs

  8. #8
    Quote Originally Posted by Martin RXT-X View Post
    Supercharger bearing failure. At 72 hrs
    Okay, than you ride very hard, like me

    Do you ride in the Ocean, or on a River...or Lake ?

  9. #9

    Join Date
    Jul 2012
    Location
    Ontario canada
    Posts
    10
    Dash would say" fuel sensor faulty "then show empty on the gauge,dealer changed it out,34 hours on ski now. Awesome ride!

  10. #10
    Best jetSki at the Time !! And i think, that will be not change for the next 5-8 years like the old RXP with 215 Horse Power !!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems With My RXP
    By W35LEY in forum 4-Tec Performance
    Replies: 19
    Last Post: 07-12-2007, 12:45 PM
  2. Any problems with 120 mains on a 1200 GPR?
    By mrbtd in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-27-2007, 02:10 PM
  3. Still have a problem with my RXP.....
    By LiquidDI in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-04-2006, 01:18 AM
  4. OMG Problem with my rxp and myself!!!!
    By ADAMBOMB in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-20-2006, 09:55 AM
  5. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •