Page 1 of 9 1 2 3 ... LastLast
Results 1 to 10 of 88
  1. #1

    new SC clutch not good with ET137

    hello,

    I'm running a new SC clutch with ET-137 on a RXT-260. shim to 17nm ---> slipping
    There are still people with these problems ?

    Thanks

    Mike


  2. #2
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    I put some mcmaster washers and 2 shims to get it to hold, and I had to play with the washer configuration, I don't remember how I did it but see sno's suggestions below, ()((( plus there is a good sticky on the subject
    As long as you face the first and last washers against the Scer like this-- Scer )you can configure them any way you want to get the slip you want...You just need them two washers to face that way so the front washer pushes against the thrust washer, and so the collar and lock nut pushes on the last washer applying the tension on the system

  3. #3
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    The new black OEM kit washers are working great for me. Is everything brand new, clutch washers, SCer gear, drive plate/washers, McMaster spring washers? You do need to ckeck and adjust slip a few times though. I believe on the high boost charger this is a must.

  4. +1 by:


  5. #4
    Yes all new. I have test the slip 4 times. Slip is good. I have no MCMaster washers

  6. #5
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by mmvane2 View Post
    Yes all new. I have test the slip 4 times. Slip is good. I have no MCMaster washers
    I always use the McMaster washers. The stock spring washers in the OEM kit will not get the slip high enough.

  7. #6
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,693
    +1
    40
    Quote Originally Posted by jp1300r View Post
    The new black OEM kit washers are working great for me. Is everything brand new, clutch washers, SCer gear, drive plate/washers, McMaster spring washers? You do need to ckeck and adjust slip a few times though. I believe on the high boost charger this is a must.
    Me too OEM washers and brand new parts work fine!!!

  8. #7
    Here my rpm's

    holeshot-->7500rpm 2seconds ---->8350rpm. There is a slip for 2 seconds.

  9. #8
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by mmvane2 View Post
    Here my rpm's

    holeshot-->7500rpm 2seconds ---->8350rpm. There is a slip for 2 seconds.


  10. #9
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    carbon ring leaking air thru the bellows??

  11. #10
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Try this. Go out and ride your ski. Hold the rpm's as close to 6000 as you can for about 3-4 minutes, then pull full throttle. If the ski hesitates or seems like it bogs, then your SC clutch is slipping.

Page 1 of 9 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ok new numbers still not good though
    By ucf_motorcycle in forum Yamaha Old School Skis
    Replies: 20
    Last Post: 05-15-2010, 03:58 AM
  2. New Ebay Motors - NOT good
    By 32DegH2O in forum Polaris Open Discussion
    Replies: 8
    Last Post: 03-07-2008, 05:49 PM
  3. Not new, just rebuilt (starter) Good deal!!
    By SideFX in forum 2-Stroke Performance
    Replies: 0
    Last Post: 09-13-2007, 11:50 AM
  4. Help With sc Clutch
    By bayline03 in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-17-2006, 02:39 PM
  5. Was not impressed with new IC any ideas??
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-10-2005, 11:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •