Results 1 to 9 of 9
  1. #1
    Avi8tor's Avatar
    Join Date
    May 2012
    Location
    Greenville, NC
    Posts
    826
    +1
    27

    Slight surge at WOT , could it be too rich or compression causing it to pull timing?

    My gprxp ski has 8650 riva ECU , xcharger, 9.5 pistons 60lb bosch injectors and powercommander to adjust fuel.
    I've got 0 values in all 100% throttle settings so effectively the cmd shouldnt be doing anything.

    When doing top speed runs holding wot, feel a very slight surge. Seems to max out approx 8400 rpm 91mph . The rpm gauge seems to be fairly steady, boost steady and the afrs fluctuating between 11.4 and 11.7
    Could the surge be because too rich afrs or perhaps even though running premium 91 octane gas its sensing a knock and retarding ?

    If normal, I wont sweat it, just want to make sure not an issues that needs to be addressed. The ski runs great all around other than that.
    Idle afrs 13.2-13.5
    60mph cruise 13.5
    70mph cruise 13.0
    80mph 12.2
    90mph 11.5


  2. #2
    Autism Speaks. Its Time To Listen gOt BoOsT's Avatar
    Join Date
    May 2011
    Location
    Cali
    Posts
    1,413
    +1
    51
    If it feels "jerky" like on, off, and back on power real quick its pulling timing. 11.4~11.7 isnt rich...11.5 is perfect IMO

  3. #3
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    mine does that at wot too sometimes. stock ecu. not sure why it would be pulling timing unless i'm on the limiter...

  4. #4
    Avi8tor's Avatar
    Join Date
    May 2012
    Location
    Greenville, NC
    Posts
    826
    +1
    27
    Quote Originally Posted by gOt BoOsT View Post
    If it feels "jerky" like on, off, and back on power real quick its pulling timing. 11.4~11.7 isnt rich...11.5 is perfect IMO
    I wouldn't describe it as real jerky, although it is noticable. It doesnt seem to lose speed when doing it.
    Feels more like its accelerating, then maintains, acceleration , maintains, acceleration...
    It does feel like how I'd imagine it would if taking timing away or even a lean surge though the afrs dont show it.

  5. #5
    Avi8tor's Avatar
    Join Date
    May 2012
    Location
    Greenville, NC
    Posts
    826
    +1
    27
    Quote Originally Posted by jhill19 View Post
    mine does that at wot too sometimes. stock ecu. not sure why it would be pulling timing unless i'm on the limiter...
    I felt it with my stock ecu as well, but just figured it was because I was close to or on limiter. I should be a couple hundred rpm shy of it with xcharger and this ecu. With the rude2 charger it hits the rev limiter so fast its only good for a couple mph and I have to manage the throttle too much so Im just leaving it off for now.
    Is the dash tach pretty accurate on seadoos? Thats all im using for reference ? I guess I can pull a 60 sec history with candoo and see what the ecu was seeing?

  6. #6
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Quote Originally Posted by Avi8tor View Post
    Quote Originally Posted by jhill19 View Post
    mine does that at wot too sometimes. stock ecu. not sure why it would be pulling timing unless i'm on the limiter...
    I felt it with my stock ecu as well, but just figured it was because I was close to or on limiter. I should be a couple hundred rpm shy of it with xcharger and this ecu. With the rude2 charger it hits the rev limiter so fast its only good for a couple mph and I have to manage the throttle too much so Im just leaving it off for now.
    Is the dash tach pretty accurate on seadoos? Thats all im using for reference ? I guess I can pull a 60 sec history with candoo and see what the ecu was seeing?
    I think they're fairly accurate. you could ride with candoo hooked up to the laptop like you did with the cmd. but I don't think you can read the knock sensor.

  7. #7
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Riva recommends 93 octane min for there ECU and with the 9.5's you may be knocking. Put your scope to use and have a peek at the piston edges.

  8. #8
    GPRXP vspec1's Avatar
    Join Date
    Jun 2009
    Location
    Orlando, Fl.
    Posts
    1,517
    +1
    253
    What do the plugs look like?

  9. #9
    Avi8tor's Avatar
    Join Date
    May 2012
    Location
    Greenville, NC
    Posts
    826
    +1
    27
    Plugs and pistons look good. Doesnt seem to be any apparent issues there.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 gti surging at wot
    By 4pinwink in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-16-2012, 11:57 AM
  2. 1999 polaris slh 700 slight bog at WOT
    By garethgreen in forum Polaris Open Discussion
    Replies: 0
    Last Post: 06-20-2012, 09:34 PM
  3. 96 XP surges at WOT
    By mcrowe in forum 2-Stroke Performance
    Replies: 10
    Last Post: 07-13-2011, 08:54 AM
  4. 98 XPL surging at WOT
    By race24x in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-11-2008, 06:39 PM
  5. Engine surging at WOT
    By Fandini in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 06-29-2008, 09:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •