Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 42
  1. #1

    Stage 1+ RXPX being beat by stock RXPX???

    Hi, my friend and I just bought a pair of 09 RXP-X's. His is bone stock with 27 hours on it, and mine is a modified ski with 60 hours of use. My 09 has a complete a complete riva stage one (intake grate, wedge, filter kit, impeller, vts extension), plus the OPAS block offs, water-box, and the high flow exhaust (non-hull through). For some reason my friends ski not only gets me out of the hole, but has been running the same top speed -with little to no lead by my ski. I thought he was just a better rider than me so we switched ski's and ran again, (and again) with the same outcome... Is this common for all of these mods to have little to no gain over stock? The previous owner of my ski claimed 74.6 on a GPS. My buddy wanted to do the Riva stage 1 kit, but after yesterday hes keeping his stock.


  2. #2
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    There's definitely something strange going on. What are your max RPMs? Do you have a GPS to use for testing speed on both skis? Hopefully your pump tunnel isn't damaged. A quick check of your pump tunnel, intake grate and prop for damage would give some peace of mind. Hopefully the previous owner didn't pull a fast one like replacing the supercharger with a stock 215 charger.

  3. #3
    No, I doubt he replaced the X charger with a 215. The ski is still under factory warrantee. It was purchased as a left over in 2011, so this is only the second summer its been in the water. The previous owner was going strictly for top speed he said, and spent a lot of money in the process. Its weird, my ski feels so much faster (both of us agree), but it lags once lined up against the stock ski. Could this be due to the high flow exhaust creating a loss in low end power? (i know this is a common problem when dealing with a car; throw on a huge exhaust on and you gain top end but suffer a loss at the bottom end) It seems like although he takes me at the start, we end up being side by side and that's where we stay.

    Ill note my max rpm's next time I go out. and as for the GPS, it was lost at the bottom of the river last time - so I need to buy a new one... Pump tunnel damage- Ill check, but my initial overview did not show any. The ski is very clean for an 09.

    I was looking through the forum and saw two mods that may be worth doing. With the use of the wedge and VTS extension rod. Should I trim my reverse gate? I'm also going to fill my ride plate holes (but not sure if that is proven to have any real benefit)

  4. #4
    TDR's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    727
    +1
    10
    Na exhaust has nothing to do with it. If you know your RPM's then we can tell if something is wrong. Might be your prop, could be bent a little.

  5. #5
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    808
    Filling the ride plate holes definitely gives some speed. Trimming the reverse gate is usually a good idea with the wedge installed.

    Quote Originally Posted by My09RXPX View Post
    No, I doubt he replaced the X charger with a 215. The ski is still under factory warrantee. It was purchased as a left over in 2011, so this is only the second summer its been in the water. The previous owner was going strictly for top speed he said, and spent a lot of money in the process. Its weird, my ski feels so much faster (both of us agree), but it lags once lined up against the stock ski. Could this be due to the high flow exhaust creating a loss in low end power? (i know this is a common problem when dealing with a car; throw on a huge exhaust on and you gain top end but suffer a loss at the bottom end) It seems like although he takes me at the start, we end up being side by side and that's where we stay.

    Ill note my max rpm's next time I go out. and as for the GPS, it was lost at the bottom of the river last time - so I need to buy a new one... Pump tunnel damage- Ill check, but my initial overview did not show any. The ski is very clean for an 09.

    I was looking through the forum and saw two mods that may be worth doing. With the use of the wedge and VTS extension rod. Should I trim my reverse gate? I'm also going to fill my ride plate holes (but not sure if that is proven to have any real benefit)

  6. #6
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    Sounds like you need a good tune-up,
    Other than checking for damage to the prop / wear ring ect, a good clean, proper sliping charger and fresh plugs can make the world of diffrence.

  7. #7
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    imagine that, yet another Riva kit that doesnt deliver.....Hmmmmm

  8. +1 by:


  9. #8
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,999
    +1
    1,482
    The stock px grate is an anchor. Replacing it (he did) allows more top speed without additional mods.
    Something is holding it back.
    Good luck!

  10. #9
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Any cavitation out of the hole? We need to know your rpms to determine if anything is wrong. You should easy run 73+ which will outrun a stocker with ease.
    I always start with a fresh set of plugs. If you are using the 3" intake from Riva, there is a decent chance at some stage you have ingested water which will foul the plugs. The Riva intake is sh!t.

  11. #10
    I am an avid supporer in changing spark plugs, but I have completely overlooked that issue. I will change the plugs tonight and I hope to take out the ski to mark the RPM's. (its almost october and im in NY so its starting to get cold here haha) As for the Riva intake, yes I am running that on my ski, so I hope that was the only problem. Ill get back to you all. Thank you for the help!

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva stage 1 rxpx 2012
    By Goodtimes in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-26-2012, 07:26 PM
  2. First 2010 Stage 1 RXPX?
    By MacDaddy_rxpx in forum 4-Tec Performance
    Replies: 12
    Last Post: 04-04-2010, 10:04 AM
  3. BOOO!! Stock SHO Cruiser beat by 2007 RXT(215) StageI
    By Toobold in forum Yamaha PWC Performance (4-stroke)
    Replies: 64
    Last Post: 07-30-2009, 03:56 PM
  4. Does anything have to be done to stock carbs if you go w/Ocean Pro Vortexs
    By jarcynvicnchris93 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 05-11-2008, 01:30 PM
  5. What should the speed be of a "stock" 2005 RXT?
    By BrAinZ in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 06-05-2006, 07:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •