Results 1 to 3 of 3
  1. #1
    Davidrf59's Avatar
    Join Date
    May 2012
    Location
    Montreal Quebec Canada
    Posts
    41

    2012 RXP-X IBR Module Failure

    BRP needs to find a new apporach to customer service beyond dismissing their customers issues. Safety should be of primary concern. Failed IBR modules create a dangerous situation, as when they fail at the time of starting the machine, it no longers starts in neutral, it leaps forward, and since the module has failed, both the brake and the reverse do not function either.
    First natural response to that forward lurch with this new technology is to grab the brake or try to put it in reverse, but neither will function. All within a second or so wham.....slam leg and foot first into the dock, getting pretty banged up and bloody. The dashboard lights up with all the messages of failure and warnings, but if this is an intermittent electronic failure, when it goes to the dealer for diagnostic, it may not show up.....hence....you are screwed as a customer.

    Contacted BRP, filled out a monster "Incident Report" spoke to one person after waiting weeks, and being on hold to reach him for close to 20 minutes......File passed to the next robot....waited more weeks, and finally was called to tell me " Sorry, nothing showed up on the diagnostics.....so we have no proof, and hence....we will do nothing for you" Regardless that the tech from the dealer who picked up the machine saw it with the IBR Gate locked up in the upper position....he decided to tow it to the launch for safety. It was only restated again in the Dealers shop.

    Thanks BRP for all the confidence in my brand new 2012 RXP-X.....top of the line machine. I have bought 9 Sea-Doo's over the past 13 yrs, and now have such utter dissapointment in your company and your products.

    Shame.....I so love my Sea-Doo.....look forward like crazy to our short summers here in Quebec....home of the manufacturer of the product, and now I start it like a gangster starting his car and hoping it doesnt have a bomb underneath so when the ignition is lit.......KABOOM !!!! or in my case .......KERSLAM!!!


  2. #2
    chillindamost02's Avatar
    Join Date
    Aug 2012
    Location
    Prairieville, Louisiana, United States
    Posts
    135
    +1
    10
    I this problem. They reprogrammed the computer and cut a few tie wraps which where pulling on wires and it has happened since. When it happened to me I took a picture if the error codes

  3. #3
    Davidrf59's Avatar
    Join Date
    May 2012
    Location
    Montreal Quebec Canada
    Posts
    41
    Quote Originally Posted by chillindamost02 View Post
    I this problem. They reprogrammed the computer and cut a few tie wraps which where pulling on wires and it has happened since. When it happened to me I took a picture if the error codes
    Error code or not, it doesnt seem to store it if the problem is intermittent and then goes away. Souns like a real low-tech info keeping computer. Point being....it should warn you before hitting the start button....not after. POS....And BRP is sucking wind in doing anything to compensate for the injury or at the barest of minimums offering to replace a faulty module. I have owned 9 machines, 6 purchased from brand new including this one....the first with Ibr, and potentially my last. Sad....I love my Sea-doo's, but maybe its time to look at Yamaha and Kawasaki. The voice of one little customer complaint should resonate loudly enough, as todays social media, and worldwide reach of the consumer, the voice grows louder. Very very surprised at BRP, a company I had only wonderful and great thing to praise....now they are like the old Bell Telephone, a large uncaring company that drove their competitors to outgrow them simply because of customer service.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 10
    Last Post: 07-07-2015, 10:30 AM
  2. 2012 rxp x iBR and ECU not found!!!
    By Tom9960 in forum 4-Tec Performance
    Replies: 19
    Last Post: 06-27-2014, 09:38 PM
  3. 2012 RXPX iBr Module Error
    By saltyqld in forum 4-Tec Performance
    Replies: 29
    Last Post: 05-19-2014, 05:42 PM
  4. 2012 RXP-X 260 supercharger bearing failure
    By Martin RXT-X in forum 4-Tec Performance
    Replies: 15
    Last Post: 03-29-2014, 03:37 PM
  5. people who have removed the ibr module on 2012 px we have a question
    By STSPERFORMANCE in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-22-2013, 10:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •