Results 1 to 5 of 5
  1. #1
    yems's Avatar
    Join Date
    Apr 2012
    Location
    Tauranga, New Zealand
    Posts
    45

    Seadoo oil pressure sensor strikes again!

    well i bought my rxtx at 32 hours. at 38 hours i replaced my first oil press sensor. iv done 43 hours, and now iv got the OIL code coming up again. could this be another failed sensor? how many of these sensors are people going through? is there a superseeded part to replace these sensors that done fail? nothing worse than coming into the beginning of summer and our first day cut short by niggly little faults.


  2. #2
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    might have a wiring issue or bad oil pressure regulator in the pto housing as the later sensor were not that unreliable

  3. #3
    yems's Avatar
    Join Date
    Apr 2012
    Location
    Tauranga, New Zealand
    Posts
    45
    the last one i had was passing oil, which i assume was creating too much resistance and causing the light to come on. as you can see in this thread i posted a few weeks back, http://www.greenhulk.net/forums/show...x+oil+pressure on page 2, the picture of the sensor i put up, its dripping oil from the centre. After replacing it (with the current sensor) i had no issues and the fault went away.. untill now same issue. iv just pulled the sensor and had a look, and same thing, its passing oil through the centre.

    I also pulled the oil filter while i was there to have a look, and i noticed it has seperated. if you hold the top and bottom you can twist and all the filter media has started to distort and fold in. :S

  4. #4
    To much is never enough Badvgood's Avatar
    Join Date
    Jun 2012
    Posts
    699
    +1
    31
    See post 57 on this thread - http://www.greenhulk.net/forums/show...t=50324&page=6

    Is your oil filter collapsing like this? If so it could be a you have small amounts of antifreeze mixing in the oil. Most of it burns off but the glycerin remains and turns to slime and clogs the filter causing the collapse.

    Have you checked your oil pressure? You may have two faults, 1 to much oil pressure & 2 an antifreeze leak internally.

  5. #5
    To much is never enough Badvgood's Avatar
    Join Date
    Jun 2012
    Posts
    699
    +1
    31
    See post 57 on this thread - http://www.greenhulk.net/forums/show...t=50324&page=6

    Is your oil filter collapsing like this? If so it could be a you have small amounts of antifreeze mixing in the oil. Most of it burns off but the glycerin remains and turns to slime and clogs the filter causing the collapse.

    Have you checked your oil pressure? You may have two faults, 1 to much oil pressure & 2 an antifreeze leak internally.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. oil pressure sensor???
    By rossi in forum 4-Tec Performance
    Replies: 46
    Last Post: 06-06-2009, 05:18 PM
  2. oil pressure sensor 2003 r12x
    By 66mrk66 in forum Honda Open Discussion
    Replies: 3
    Last Post: 03-30-2009, 08:44 PM
  3. WTB: 4tec oil pressure sensor.
    By Water4fire in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 03-12-2009, 09:04 AM
  4. Rear oil pressure sensor - Where is it?
    By PatrickB in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-10-2008, 06:48 AM
  5. Low oil Pressure Sensor Threads
    By kc8lbn in forum Honda How To & FAQs
    Replies: 1
    Last Post: 03-12-2008, 08:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •