Results 1 to 3 of 3
  1. #1
    thetolleyman's Avatar
    Join Date
    Jul 2010
    Williamsburg, VA

    Found blocked Rave valve vacuum line, could that be my problem?

    Been trouble shooting a 951 carb model, its maxing out at around 4300 rpm lately. Starts easy and runs fine. Just found that the rear rave valve wasn't functioning at all, the vacuum port was completely blocked with some white hard material, had to drill it out. Seems to be working fine now, at least on the bench. Could a non-functioning rave valve have caused the RPM limitation?

  2. #2
    diamondwatercraft's Avatar
    Join Date
    Apr 2007
    SE Michigan
    Yes. The raves open to get top rpm's. If it was not opening then you were not at top rpm's.

  3. #3

    Join Date
    Aug 2007
    East of DFW
    Non working raves wont allow motor to rev over 6300 rpm. At 4300 I would think its not fining on both cylinders.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 GTX and Rave Valve Adjustment, fuel lines too?
    By Reefer in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-27-2009, 07:39 PM
  2. Vacuume Line install for blowoff valve
    By Fatty in forum 4-Tec Performance
    Replies: 9
    Last Post: 10-12-2007, 09:13 PM
  3. Cleaned my rave valves, found loose clamp
    By gbest in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-08-2007, 01:56 PM
  4. wide rave valves
    By jetski_waxhead in forum 2-Stroke Performance
    Replies: 16
    Last Post: 02-08-2007, 08:37 AM
  5. plugging vacuum line for bov
    By excess in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-16-2006, 07:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts