Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    2002 Yamaha FX140

    Hello, new member from Southern California.
    I was searching for help while working on the '02 FX140. Found what I needed and am very appreciative. So I figured I would join.

    I'm a very automotive guy, but have never previous worked on watercraft. Well, my father in law has an '02 and an '07 Yamaha. The '02 was having issues, so he had me take a look since a 4stroke is a 4stroke, on or off the water. (His words, not mine.)

    Anyways, that's how I got into the sport. Now, it's like modding a car. I just want to mod it!! (Even though its not really mine...)

    I will post pics tomorrow.


  2. #2

    Join Date
    Apr 2008
    Location
    Miami Fl
    Posts
    161
    +1
    3
    I have some bold on mods from my previous FX140 that you could get at a good price. let me know.

  3. #3
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,591
    +1
    4,798
    Welcome to the forum! Start by dumping that restrictive OEM air filter setup and install the Velocity Stack Kit with the Riva Power Filter/Arrestor; you can find these in Jerry's store and they worked great on our FX-140's. You can find these two items at the bottom of this page:
    http://www.4-tecperformance.com/inde...ex&cPath=16_24

  4. #4

    2002 Yamaha FX140

    Thanks. I saw the Riva Stacks, and I like!! I'm waiting to see what my father-in-law does with it. A lot depends on Sunday and whether or not it actually is fixed for sure.

    Originally, it would run great in the drive way, but once we put it on the water, it wouldn't go above idle. I replaced the throttle positioning sensor, put it on the water last weekend, and it ran great... until about 30mph. I pulled it back apart in the garage, and one of the seals for one of the fuel injectors was missing. Got that put on, started her up, and she sounds great. But we'll see.

  5. #5
    i had the same thing happen to me it was the wires that plug into the coil believe it or not it sounds great on the trailer running on 2 cylinders put it in the water no power i would check your spark if you havent 1 and 4 fire together and 2 and 3 fire together

  6. #6

    2002 Yamaha FX140

    Quote Originally Posted by sustaita1 View Post
    i had the same thing happen to me it was the wires that plug into the coil believe it or not it sounds great on the trailer running on 2 cylinders put it in the water no power i would check your spark if you havent 1 and 4 fire together and 2 and 3 fire together
    Hm. Makes sense. There's no load on it in the driveway, so it doesn't need any power, but in the water, the two cylinders can't quite do it. I'll check them today after work. Thanks!!

  7. #7

    2002 Yamaha FX140


  8. #8

    2002 Yamaha FX140

    Taking her out tomorrow. We'll see how she runs!!

  9. #9

    2002 Yamaha FX140

    HELP!!

    Perhaps the most frustrating day I've ever had.
    Took it out in the water. It ran perfect, revved up to its 10k potential, and flew on the water, about 5 minutes into the day, it stopped. Wouldn't go above 5k rpm, and no faster than 12-15mph. Docked it, took off seat, noticed that the fuel line hose clamp was really tight. Thought maybe it was restricting fuel. I loosened the screw 1 turn. Put the seat back on, started it up, got on turned out from dock, and it died. Wouldn't start back up. Still wont start back up.

    It was 1/3 tank this morning, I added fresh fuel to 3/4 tank, along with Yamalube Ring Free + before I headed out.

    After the issue, I've checked plugs and spark. All good. Checked injectors, three were good, one was bone dry. So I know one is bad, the other three could probably use a good cleaning. Could this really cause this?? Could one bad injector cause the ski to not start?? And why did it run perfectly, then suddenly big down?? I checked the impeller and that's not the issue.

  10. #10

    Join Date
    Apr 2008
    Location
    Miami Fl
    Posts
    161
    +1
    3
    check filter and spark plugs.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts Looking for ride plate and intake gate for 2002 Yamaha fx140..
    By RIVERA RACING in forum Yamaha 4 Stroke Skis
    Replies: 2
    Last Post: 12-14-2013, 06:05 PM
  2. FS 2002 Yamaha FX140 Project Ski For Sale $1,500
    By Canadian Swamp King in forum Yamaha 4 Stroke Skis
    Replies: 1
    Last Post: 04-19-2013, 12:27 AM
  3. 2002 Yamaha FX140 Project Ski For Sale $1,500
    By Canadian Swamp King in forum Canada Rides
    Replies: 1
    Last Post: 04-19-2013, 12:09 AM
  4. SOLD 2002 Yamaha FX140 $4200
    By BPnta in forum Yamaha 4 Stroke Skis
    Replies: 2
    Last Post: 05-01-2012, 04:20 PM
  5. FS 2002 Yamaha FX140 Partout
    By BombThreat in forum Yamaha Classifieds
    Replies: 6
    Last Post: 01-21-2012, 11:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •