Page 1 of 8 1 2 3 ... LastLast
Results 1 to 10 of 78
  1. #1
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77

    New Flywheel install issues 08 RXP-X

    Ok, So I had to install a new flywheel from an SC failure. Flywheel is from an 04 (using my magneto and cup). First I installed it and totally forgot about aligning the crank pin with the flywheel. OF course it would not start. Today I got around to taking it back apart. The crank pin was mushroomed a bit so I drilled out the small hole in the flywheel to match the size. Aligned it to the small hole on the cup and reinstalled. Still it will not start, just one backfire and that was it.

    Can someone possibly post up a pick of how it looks when it is correctly installed? (flywheel to magneto cup pic) I felt sure I had it right today and Im about tired of pulling the PTO lol.

    any help is appreciated.


  2. #2
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Bump, need someone to give me a pic or post of a shop manual page if possible on how to install the magneto/cup correctly.

  3. #3
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Eric, I can send you the relevant pages from the 2008 shop manual when I get home from work if you like.

  4. #4
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by monaroman76 View Post
    Eric, I can send you the relevant pages from the 2008 shop manual when I get home from work if you like.
    I found the shop manual and have checked it out. THe first time I did it all wrong and mushroomed the crank pin a bit. Hoping this didnt jack something up. Today when I reinstalled I was more than certain I did it right but I must not have the trigger wheel in the correct spot.

    I think I really need a picture. The shop manual is not helping to much

  5. #5
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by Ocman View Post
    Quote Originally Posted by monaroman76 View Post
    Eric, I can send you the relevant pages from the 2008 shop manual when I get home from work if you like.
    I found the shop manual and have checked it out. THe first time I did it all wrong and mushroomed the crank pin a bit. Hoping this didnt jack something up. Today when I reinstalled I was more than certain I did it right but I must not have the trigger wheel in the correct spot.

    I think I really need a picture. The shop manual is not helping to much
    Its because the crank pin locations are different from early to late engines, its the same as when fitting a late crank in early engine (PTO because of the cps location)

    You will have to remove thwe pin and effectively rotate the mag on the crank think its 2 holes anti clockwise but im not 100% its deff 2 holes but cant remember which way.

    Hope that helps some. R88

  6. #6
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    +1

    04' is different I heard....

  7. #7
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    oh wow.. new news to me!! Is it just the 04 flywheel??

  8. #8
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,062
    +1
    790
    Quote Originally Posted by R88ory RXP View Post
    Quote Originally Posted by Ocman View Post
    Quote Originally Posted by monaroman76 View Post
    Eric, I can send you the relevant pages from the 2008 shop manual when I get home from work if you like.
    I found the shop manual and have checked it out. THe first time I did it all wrong and mushroomed the crank pin a bit. Hoping this didnt jack something up. Today when I reinstalled I was more than certain I did it right but I must not have the trigger wheel in the correct spot.

    I think I really need a picture. The shop manual is not helping to much
    Its because the crank pin locations are different from early to late engines, its the same as when fitting a late crank in early engine (PTO because of the cps location)

    You will have to remove thwe pin and effectively rotate the mag on the crank think its 2 holes anti clockwise but im not 100% its deff 2 holes but cant remember which way.

    Hope that helps some. R88

    Edit and re posted. (not flywheel, but trigger) Correct, and i would just get a newer flywheel so you know it is correct instead of it you think you drilled it wright. Why bother and have to worry about it.
    Last edited by Water4fire; 10-08-2012 at 12:42 PM.

  9. #9
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    I agree with water4fire here, it would be best to get the right flywheel, I know that you can just remove the pin and turn the mag and they run but Im not 100% convinced that it lines the timing up perfect as far as the ignition is concerned.

    This is all because they moved the crank sensor in 06, it now at like 7-8 0 clock on the bottom of the pto as opposed to being at 12 inside the pto on the early engines.

    My 04 engine has a late crank, but I have standalone so know the timing is perfect, you cant change the base timing in the stock ECU.

  10. #10
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    I was told the flywheel is the same?? Im not using the magneto and cup from the 04. Im using the mine. so the 04 flywheel is the issue??? I was under the impression its only related to the trigger wheel when it comes to timing?

Page 1 of 8 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 05-07-2010, 02:18 PM
  2. FS New 2008 Speedfreaks modded 08+ RXP/T-x Rideplate
    By boostaholic in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 12-23-2009, 12:41 AM
  3. FS New 08 RXP 215hp $9999
    By RXPRacer513 in forum Sea Doo 4Tec Skis
    Replies: 0
    Last Post: 05-28-2009, 06:08 PM
  4. Any new Gibson Installs on RXP ??
    By MIARider in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-17-2008, 09:33 PM
  5. SPY photos fo the new redesigned 08 RXP !!
    By beached log in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 12-08-2006, 08:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •