Results 1 to 2 of 2
  1. #1
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598

    2000 ultra 150 charging system problem

    i need some advice on a ultra 150 charging system, the ski has a new battery, i tested the stator, its good, putting out the required AC voltage 32-48 @ 3000rpm, all the connections are good and clean, but its not charging, any ideas guys ???????


  2. #2
    Spooling's Avatar
    Join Date
    Sep 2011
    Location
    West Coast of Florida
    Posts
    1,285
    +1
    177

    Sounds Like the Voltage Regulator

    Quote Originally Posted by big john View Post
    tested the stator, its good, putting out the required AC voltage 32-48 @ 3000rpm, all the connections are good and clean, but its not charging
    -----------------

    Regulator/Rectifier P/N # 21066-3715

    Reference:

    http://ultra150.yuku.com/reply/20001...ht#reply-20001

    http://ultra150.yuku.com/reply/25086...ay#reply-25086

    Good Luck !!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 Ultra 150 fuel system problems
    By hel-bent in forum Kawasaki PWC Performance (2-stroke)
    Replies: 13
    Last Post: 04-21-2015, 08:17 PM
  2. My 2000 ultra 150 gps'd yesterday.
    By jcc011185 in forum Kawasaki Open Discussion
    Replies: 76
    Last Post: 05-08-2008, 06:42 PM
  3. My new 2000 ultra 150
    By jcc011185 in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 08-03-2007, 05:38 PM
  4. Ultra 150 Charge Testing
    By twinstack1 in forum Kawasaki Tech Tips and Info
    Replies: 0
    Last Post: 06-21-2007, 10:26 AM
  5. 99 Ultra 150 an weird problems
    By xplayer2885 in forum Kawasaki How To & FAQs
    Replies: 8
    Last Post: 09-21-2006, 03:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •