Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339

    '12 PX Start/Stop button NG

    Had to replace my start/stop switch today @ 66 hrs. The button was really starting to act up and would sometimes need lots of manipulation and cursing to get it to work. First problem I've had with the ski though... the new switch works like butter.


  2. #2
    TDR's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    727
    +1
    10
    Yep same with mine, its kinda moving to the side and getting stuck under the housing. Have to keep moving it out.

  3. #3
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    Mine was positioned in the housing ok. Even once I had the old one out and on the bench with a meter, it was acting up intermittently. Pushing on it extremely hard will always ohm it out...

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Damn Vic. You have been riding that thing, 66hrs. You have passed me up. I am at 56 hrs.

  5. #5
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    Quote Originally Posted by troyheb View Post
    Damn Vic. You have been riding that thing, 66hrs. You have passed me up. I am at 56 hrs.
    You're lucky enough to be in Texas though... so I wont be ahead of you for long.

  6. #6
    TDR's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Australia
    Posts
    727
    +1
    10
    I read the first sentance wrong, you replaced the switch not the accul button haha. Woops! My swtich is fine its just the button thats going into the housing all the time.

  7. #7
    Banned User
    Join Date
    Sep 2009
    Location
    Aussie Land
    Posts
    804
    +1
    21
    Mine is a prick to push, almost have to use nail to get it to actuate.

  8. #8
    ecpChris's Avatar
    Join Date
    Jul 2007
    Location
    ocean county nj
    Posts
    2,912
    +1
    427

    '12 PX Start/Stop button NG

    The button is a prob on 2011 and up. For some reason 2010 ibr skis are fine. Mine is fuct too

  9. #9
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    Quote Originally Posted by lolzer View Post
    Mine is a prick to push, almost have to use nail to get it to actuate.
    Funny you say that- I could see some fingernail marks on the switch cover (red button).

  10. #10
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Mine is kinda off center, but seems to work fine. My start stop button that is.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 12' gtr 215 start/stop button replacement?
    By Nick_R in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-05-2015, 03:05 PM
  2. DESS key starts RXP w/o Start - Stop Button!!!!
    By OneEyedHito in forum 4-Tec Performance
    Replies: 22
    Last Post: 01-28-2011, 11:21 AM
  3. Start/Stop button operation??
    By IndyAl in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-07-2009, 11:32 AM
  4. start stop button problem?
    By watereater in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-14-2009, 07:51 PM
  5. start/stop button malfunction?
    By adrenalin in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 06-01-2006, 11:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •