Results 1 to 2 of 2
  1. #1
    caliburn's Avatar
    Join Date
    Aug 2012
    Location
    Sister lakes Mich
    Posts
    531
    +1
    12

    01 gp1200r jet pump rod

    Noticed what seems to be on one side were the rod connects with the other factory shaft that there is a small a crack that you can feel, the other side is smooth, is this a factory defect, or is this normal? thanks for your help.Click image for larger version. 

Name:	IMG_0661.jpg 
Views:	39 
Size:	64.5 KB 
ID:	285303Click image for larger version. 

Name:	IMG_0662.jpg 
Views:	39 
Size:	67.8 KB 
ID:	285304Click image for larger version. 

Name:	IMG_0664.jpg 
Views:	34 
Size:	63.1 KB 
ID:	285305


  2. #2
    caliburn's Avatar
    Join Date
    Aug 2012
    Location
    Sister lakes Mich
    Posts
    531
    +1
    12
    anyone??? about this impeller shaft???

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 01 GP1200R jet pump 66v will not fit to long????? help pls.
    By caliburn in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 11-24-2012, 01:25 AM
  2. FS 01 GP1200R with 07 GP1300R FI engine/pump $$??
    By SeadooTech in forum Yamaha 2 Stroke Skis
    Replies: 17
    Last Post: 10-19-2011, 07:04 AM
  3. Bad wear ring? or pump seal? 01 gp1200r
    By b_dolla44 in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 04-13-2011, 03:43 PM
  4. Replies: 5
    Last Post: 03-11-2010, 02:33 PM
  5. Jetting for 01 gp1200r please help
    By xprider02 in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 05-17-2008, 05:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •