Results 1 to 7 of 7
  1. #1

    Join Date
    Aug 2008
    Location
    north east uk (hartlepool)
    Posts
    238
    +1
    9

    Vx clocks not working

    Any ideas what could be causing my vx clocks not to work it's 2005


  2. #2
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    Maybe because its almost 8 years old?

  3. #3

    Join Date
    Aug 2008
    Location
    north east uk (hartlepool)
    Posts
    238
    +1
    9
    It's only 120 hours on it

  4. #4
    Jarrett's Avatar
    Join Date
    Apr 2005
    Location
    Waxahachie, TX
    Posts
    3,011
    +1
    77
    Do you mean its no longer tracking the engine hours?

  5. #5

    Join Date
    Aug 2008
    Location
    north east uk (hartlepool)
    Posts
    238
    +1
    9
    No speedo , hours ect i bought the ski from uk to Spain for a week on first day after about an hour the clocks started to flash on and off after a while it would come back on but it was lighting up everything on the dash as in oil lights hours and speedo was showing 188 . Then it all went off and now the clocks / speedo not showing anything

  6. #6

    Join Date
    Sep 2010
    Location
    Aliso Viejo
    Posts
    951
    +1
    75
    I would look into the wire harness... I think its from ECU... Post your question on PWCToday, frenchy knows everything about VX..

  7. #7

    Join Date
    Aug 2008
    Location
    north east uk (hartlepool)
    Posts
    238
    +1
    9
    Ok thanx

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2016 VX Cruiser - Pisser Not Working on Engine Flush
    By SkiPink in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 07-18-2016, 02:12 PM
  2. Yam vx deluxe clocks not working
    By dixon0001 in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 10-14-2012, 11:20 AM
  3. speedo not working
    By jetskibill9999 in forum 4-Tec Performance
    Replies: 3
    Last Post: 10-09-2005, 06:41 AM
  4. okay, not work safe. Grossest picture I've ever seen...
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 07-19-2005, 09:31 PM
  5. Speedometer Not Working
    By jack in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-25-2005, 08:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •