Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38

    Just got my RIVA/Athena ECU !

    Finally received my Athena ECU.I'm going to be using this on my pops ski which right now has a Stage 2 RIVA kit in it. Gonna also be installing the Vlave train after I test it out this weekend. I had a really bad experience with my Vi-PEC with over revs when I first installed it.
    Any questions you guys may have feel free to ask.

    Here are some teaser pics
    Click image for larger version. 

Name:	photo2ou.jpg 
Views:	153 
Size:	265.3 KB 
ID:	285609

    Click image for larger version. 

Name:	photo4gf.jpg 
Views:	106 
Size:	44.0 KB 
ID:	285608
    Click image for larger version. 

Name:	photo1cki.jpg 
Views:	137 
Size:	342.0 KB 
ID:	285610
    Click image for larger version. 

Name:	photo5rn.jpg 
Views:	104 
Size:	41.1 KB 
ID:	285611
    Click image for larger version. 

Name:	photo3lg.jpg 
Views:	128 
Size:	198.1 KB 
ID:	285612


  2. #2
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,144
    +1
    255
    SUBSCRIBED. plz let us know how it goes, i am looking for all the info possible to jump on it.

  3. #3
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    Just got it installed. It's a pretty easy install. I couldn't play around in the software because the little block in the battery pole fell inside the ski and I can't find it.

  4. #4
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,144
    +1
    255
    Quote Originally Posted by Waterholics View Post
    Just got it installed. It's a pretty easy install. I couldn't play around in the software because the little block in the battery pole fell inside the ski and I can't find it.
    10mm nut will work

  5. #5
    Leendert's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, Florida, United States
    Posts
    918
    +1
    73
    I have problems connecting to the ECU with the yellow key. It connects fine on the red key but i cant program in that mode.
    So this proves the pc and com port are fine.
    Any help or tips would be nice.

  6. #6
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    Quote Originally Posted by Private_xpl View Post
    I have problems connecting to the ECU with the yellow key. It connects fine on the red key but i cant program in that mode.
    So this proves the pc and com port are fine.
    Any help or tips would be nice.
    Kinda the same problem I'm having and that's why I havent updated the thread. I'm gonna try a next PC and see if it works.

  7. #7
    Leendert's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, Florida, United States
    Posts
    918
    +1
    73
    Try to connect with the red key hooked up please.
    If it connects you have proven that it's not the PC

  8. #8
    use the red key if engine off

  9. #9
    Leendert's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, Florida, United States
    Posts
    918
    +1
    73
    I did that but then it comes back with error codes about not being able to change things in that mode

  10. #10
    FZS Monty's Avatar
    Join Date
    Apr 2011
    Location
    Eastern Long Island, NY
    Posts
    588
    +1
    37
    Call Riva

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Newbie just got my first ski XLT 1200 - 2004 with Riva kit.
    By minigranis in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 11-29-2012, 12:33 AM
  2. Just got my intake, Riva FF, and Ribbon done.......VXR
    By JoeMomma in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 06-20-2011, 08:51 AM
  3. Just got my Riva reducer nosel and need advise
    By cwilliams21 in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-18-2010, 11:17 AM
  4. just got my Riva stage III
    By Alex13 in forum 4-Tec Performance
    Replies: 18
    Last Post: 10-05-2006, 05:34 PM
  5. just got my gps
    By PAINKILLER in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-18-2005, 05:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •