Results 1 to 2 of 2

Thread: Hi

  1. #1

    Hi

    I have 01 seadoo RX and I have the problem with no RPM only 6300 at 55mph please need help new piston open water box K&N filter and no rpm


  2. #2

    Join Date
    Aug 2007
    Location
    East of DFW
    Posts
    244
    +1
    21
    Well 6300 rpm is the magic number to suspect the RAVES are not functioning correctly. You have electrical connections, a solenoid and pressure pulse line from crankcase in the loop. Remove raves from cylinder and confirm they are clean and moving freely. If they are not stuck, remove the large springs under both caps and go test ride. See if your rpm gets up close to 7k.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP Hi temp warning
    By Bambeezer in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-30-2014, 09:15 PM
  2. 04 RXP Riva STG II Hi-Temp Alarm
    By ramnj in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-16-2006, 08:43 PM
  3. HI ! every body's
    By luckyluc31 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-15-2005, 08:26 PM
  4. Where can I get Hi Res Shoots of SeaDoo's??
    By 1 FAST VE in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 09-14-2005, 11:36 AM
  5. Hi all.. New here..
    By Saladbar in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 08-14-2005, 11:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •