Results 1 to 3 of 3
  1. #1

    Need Help! Stx15f problems

    I replaced the tube-pipe ex muffler(the blue sleeve) that is connected to the Muffler-comp it had a rip in it. The second time I took the ski out the blue sleeve had a hole blown through it again, what could be causing it. Thanks frank

  2. #2
    GZA's Avatar
    Join Date
    Sep 2010
    New Zealand
    Do a search Frankdees, it'll be due to over heating. There plenty of info on here regarding this.


  3. #3

    Join Date
    Aug 2009
    Shuswap lake, Canada
    Think this often happens because the blue sleeve isn't fit properly, even though it looks fine.
    A shortage of cooling water can also be the culprit.
    There are threads on these two issues, including the tricks required to get it right

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help diagnosing problem
    By grober02 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 08-01-2011, 06:43 PM
  2. Wierd Starter relay problem....NEED HELP???
    By jitees in forum 4-Tec Performance
    Replies: 18
    Last Post: 03-20-2010, 06:19 PM
  3. Need Help diagnosing problem
    By Sirhc7897 in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-25-2008, 09:47 AM
  4. Need Help, RXP problems, Plug pictures
    By Water4fire in forum 4-Tec Performance
    Replies: 32
    Last Post: 04-26-2007, 10:38 PM
  5. Seadoo GTX problem Need help!
    By DeeGee in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 06-17-2006, 11:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts