Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,248
    +1
    62

    Need help spark plug read..

    Why is this happening is only in #3 cylinder ,cant this be because I was running hot today.or leand...Click image for larger version. 

Name:	IMAG1880.jpg 
Views:	191 
Size:	49.8 KB 
ID:	286129


  2. #2
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,248
    +1
    62
    I was 11.5 @wot .but temp went hot today 220 2 times...

  3. #3
    check your injector

  4. #4
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by rxpredviper View Post
    Why is this happening is only in #3 cylinder ,cant this be because I was running hot today.or leand...Click image for larger version. 

Name:	IMAG1880.jpg 
Views:	191 
Size:	49.8 KB 
ID:	286129
    Hmmm, Check your injector, you running high fuel pressure???

    Maybe your getting some deto, something isnt right thats for sure.

    r88

  5. #5
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Are You running race fuel? I know you are running turbo just wondering if your running to much timming in the ecu

  6. #6
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,248
    +1
    62
    Am running e85 and and timming is the same ...55 pond of fuel at 29 boost .i open motor and no datonation on piston ..maybe over heat?????

  7. #7
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    What type injectors are you using??

  8. #8
    rxpredviper's Avatar
    Join Date
    Feb 2009
    Location
    WPB
    Posts
    2,248
    +1
    62
    inject are1150 bush,, her is the piston..Click image for larger version. 

Name:	IMAG1882.jpg 
Views:	111 
Size:	112.3 KB 
ID:	286146

  9. #9
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    475
    looks like your way too low on fuel psi, you should be in the 80+psi for enough fuel
    55-29 =26 fuel psi and bosch injectors will not work correctly below 2.5 bar (37psi)
    IMO you need to be at least 3.5 bar(50psi) actual fuel psi @ 29psi boost (50+29=79) for you to have enough fuel with e85
    your very lucky you only melted the spark plugs
    Last edited by skidoochris; 10-28-2012 at 02:55 PM.

  10. +1 by:


  11. #10
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by rxpredviper View Post
    Am running e85 and and timming is the same ...55 pond of fuel at 29 boost .i open motor and no datonation on piston ..maybe over heat?????

    Whats your EGT like???

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 GTX spark plug read help
    By wjholt in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-03-2014, 12:28 PM
  2. Need help with plugs 1 and 4.... ?
    By MR MAC in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 02-23-2011, 12:01 PM
  3. I need help all please read just incase you can help!!!!!!!!!!
    By chink0788 in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 06-22-2010, 08:03 PM
  4. Spark Plug Reading
    By la90043 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 03-02-2008, 07:29 AM
  5. I need some spark-plug analysis:
    By JP in forum 4-Tec Performance
    Replies: 58
    Last Post: 03-29-2007, 08:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •