Results 1 to 6 of 6
  1. #1

    Does any one have this issue?

    Just wonder us there any speed limiter on the 2011 gti 130 (australian version)?



    Because what happen was: every now and then at WOT, the machine will reach around 92km/h (physically the machine will not run faster than 92km/h) then suddenly the speedo jump to 102-108km/h then power dropped. Is this some sort of computer issue?



    Does anyone have the same issue?


  2. #2
    my 2012 GTI SE 130 does not do that. mine tops out at 54 MPH not sure what that is in kmh, my speedo stays steady at all speeds and does not jump around at all so I think you might have a problem, good luck and let me know what you find out

  3. #3

    Join Date
    Oct 2012
    Location
    Australia
    Posts
    100
    +1
    7
    From what I understand the speed is gps related so maybe loss of gps signal could be messing things up. You mentioned power drop, are you phisicaly feeling a loss of power?

  4. #4
    jeteffect's Avatar
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    374
    +1
    11
    My GTI 155 Limited reaches a max speed of 92km/hr. But I've not seen the speedo jump like you've mentioned. It is governed and GPS controlled and very accurate.

  5. #5

    Does any one have this issue?

    Quote Originally Posted by ravenit View Post
    From what I understand the speed is gps related so maybe loss of gps signal could be messing things up. You mentioned power drop, are you phisicaly feeling a loss of power?
    Yes, feel like someone push you forward while the ski go other direction.

  6. #6
    im in aus and mine stops at 86-87kph

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. does any one have pics or diagrams of a 1995 sl 750 cdi box terminals
    By H2ozone in forum Polaris Tech Tips and Info
    Replies: 2
    Last Post: 05-10-2015, 05:46 PM
  2. Dynojet CMD need fuel map! Does any one have one?
    By sc281rxp in forum 4-Tec Performance
    Replies: 15
    Last Post: 06-23-2013, 03:48 PM
  3. Does any one have a pic of a driveshaft?
    By chvscks319 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-15-2009, 01:39 PM
  4. does any body have a myspace
    By Bone1050 in forum Polaris Open Discussion
    Replies: 30
    Last Post: 11-10-2007, 10:04 PM
  5. Any one have a set of pro carb jets?
    By Rodneyae in forum Polaris Open Discussion
    Replies: 10
    Last Post: 02-27-2007, 12:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •