Results 1 to 2 of 2
  1. #1
    tburn's Avatar
    Join Date
    Jun 2007

    zxi 750 performance problem

    1997 ZXI 750 is lacking acceleration like its starving for fuel but choking doesn't seem to change the situation. I have replaced the diaphrams in the carbs as well as cleaning them, I have installed a block off plate on case drain, new fuel filter and still you punch it and it takes a while for it to turn up RPMs. Could I have coil issue or something? Starts and idles great. Any help would be great. Thanks

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Have your tried running on Reserve? Could be a fuel filter or air leak in the selector valve. Have you done a compression test?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB need zxi 750 performance parts
    By rocxp in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 03-07-2010, 01:25 PM
  2. 1994 sl 750 plumbing problem
    By roushski in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 04-03-2007, 03:55 PM
  3. 780 head on a 750. Any problem?
    By xlint89 in forum Polaris PWC Performance
    Replies: 20
    Last Post: 03-04-2007, 02:44 PM
  4. challenger 180 performance problem
    By bahamadan in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 10-25-2006, 10:18 AM
  5. Performance Problems exhaust beep
    By Wolverine in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-23-2006, 07:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts